#1

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Problem tritt u.a. bei All-Inkl.com mit Einstellung "Apache als Modul" auf

Hallo,

beim Hochladen von Bildern zeigt Pro Web mir diese Fehlermeldung an. smile_confused_16.png

Könnte mir vielleicht jemand helfen?

Vielen Dank!

fehler.jpg

 


Viele Grüße Rolf   

#2

Thomas

Co-Admin  (2039 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Versuche einmal das Bild zu löschen und anschließend wieder hochzuladen, ansonsten würde ich empfehlen den Support von Siquando zu kontaktieren.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersicht & Support für Shop 10 + Pro Web 3)

#3

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Danke Thomas, geht auch nicht.

Es war mir jetzt am einfachsten das Bild per HTML Code hochzuladen.

 


Viele Grüße Rolf   

#4

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Hallo Rolf,

Du meinst wohl eher via HTML-Code integriert. ;-) Hochladen kann man nur per FTP oder SFTP (ggf. auch SCP).


Ist das Problem bei Dir allgemeingültig oder ein Einzelfall? Wende Dich wie Thomas schon sagt am besten mal an den Siquando-Support damit.


Ich habe seit dem Pro Web Build 1540 (sowie 1550) übrigens auch Probleme mit dem Hochladen von Bildern, die ich nur durch einen "komischen" Trick umgehen kann. Mit Build 1520 (und davor) tritt das Problem reproduzierbar nicht auf. Ich werde dies jedoch hier mal separat in einem neuen Thema ausführlich posten.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#5

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Ja klar Volker, genau das meinte ich ja smile_16.png

Mit 1520 hatte ich da auch keine Probleme. Mit 1550 ist das der erste versuch smile_confused_16.png Ich werde das mal bei anderen Seiten probieren


Viele Grüße Rolf   

#6

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Auf allen anderen Projekten gehts. Nur bei den einen Projekt gehts auf keiner Seite.smile_sad_16.png

Wie geht denn dein komischer Trick, Volker ?

 


Viele Grüße Rolf   

#7

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Dann handelt es bei unseren Fehlern sich um zwei unterschiedliche Paar Schuhe. Bei mir ist das Problem projektübergreifend und besteht exakt seit Build 1540 (und 1550, nicht mit 1520 und älter). Ich werde dies wie gesagt hier separat aufgreifen.

An Deiner Stelle würde ich mal folgendes probieren:

  1. Die serverseitigen Systemvoraussetzungen prüfen und abgleichen (allow_url_fopen = On usw.).
  2. Aus Projekt Central das Projekt einmal vollständig aktualisieren (Neuinstallation der Komponenten erzwingen).

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#8

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

habe Neuistallation erzwungen und geht immer noch nicht. Beim hochladen des Bildes in den Ordner " Bild auswählen " ist nach dem hochladen schon ein rotes Ausrufezeichen auf dem Bild.

ausrufezeichen.jpg

 


Viele Grüße Rolf   

#9

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Dann handelt es sich doch um den gleichen Fehler, denn genau das (!) passiert bei mir auch.

Ich werde gleich nochmal etwas detaillierter darauf zurück kommen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#10

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

O.K. - hier das Problem noch einmal so ausführlich beschrieben wie eben möglich:


Wenn ich bei meinem Provider All-Inkl.com die Einstellung "Apache als Modul" verwende, kann ich explizit keine Bilder hochladen. Nach dem Versuch des Hochladens wird ein rotes Ausrufezeichen auf dem Bild angezeigt (genau wie in Beitrag #8 illustriert).

Wenn ich die Einstellung ändere auf "Apache via FPM/FastCGI" lassen sich Bilder dagegen ganz problemlos hochladen. In diesem Fall funktioniert die Seite aber überhaupt nicht mehr. Beim Aufruf der Website kommt es zu einem heftigen PHP Fatal Error wie folgt:

 PHP Fatal Error: Uncaught Exception

Dies ist aber erst seit Pro Web Build 1540 (also auch mit Build 1550) so. Mit den Builds 1520, 1510 und 1500 trat dieses Problem nicht auf.


Ich kann daher entweder via "Apache als Modul" eine fehlerfreie Seite im Web haben, auf welche ich aber keine Bilder hochladen kann oder per "Apache via FPM/FastCGI" eine nicht funktionierende Seite, auf welche sich dann jedoch fehlerfrei Bilder hochladen lassen.

Ist das normal?


Meine "komische", eigentlich völlig inakzeptable Lösung besteht aktuell darin, daß ich die Seite via "Apache als Modul" betreibe und wenn ich Bilder hochladen möchte, diese temporär auf "Apache via FPM/FastCGI" umstelle. Während dieser Zeit, in der ich Bilder hochlade, führt der Aufruf jeglicher Seiten-URL zum o.g. PHP Fatal Error.


Hier nochmal ein paar Details:

  • Provider: All-Inkl.com
  • PHP-Version (Website funktioniert, Bilder hochladen funktioniert nicht): PHP 5.5.24 ("Apache als Modul")
  • PHP-Versionen (Website funktioniert nicht, Bilder hochladen funktioniert): PHP 5.3.28, PHP 5.4.40, PHP 5.5.24, PHP 5.6.8 (jeweils "Apache via FPM/FastCGI")

Zur Einsicht und Ursachen-Analyse habe ich alle genannten PHP-Versionen mit einer entsprechenden PHP-Info verlinkt.


@Siquando:

Da müßt Ihr bitte unbedingt und zeitnah ran! Die beschriebenen Fehler sind einwandfrei reproduzierbar und in dieser Form inakzeptabel.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#11

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

sehr, sehr traurig. Also wieder mal was verschlimmbessert smile_confused_16.png


Viele Grüße Rolf   

#12

Paulemann

Hero  (746 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.webdesign-bf.de

Tja, keine Ahnung an was das nun liegt>ich verwende auch die 1550 (Danke noch einmal Volker) unter All-Inkl und bei mir gibt es keinerlei Probleme. Erste Bild im Content gerade hochgeladen.

-----------------

Ergänzung: PHP 5.4.40


Gruß

Paulemann

Webdesign-BF - Projektbetreuung und ein wenig mehr...


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Paulemann« (01.07.2015, 16:01)
#13

Thomas

Co-Admin  (2039 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Volker, wie hast du die verschiedenen Versionen getestet?

Angenommen du installierst die Serverkomponenten mit „PHP als Apache Modul” und arbeitest mit der Seite (auf meinen Server funzt dann alles korrekt). In dem Fall werden die generierten cache Dateien und wahrscheinlich auch die Bilder und Downloads mit dem Server-Benutzer www-data oder ähnlich angelegt. Stellt man nun auf FastCGI oder Ähnliches um, fehlen die Rechte auf den Dateien des Ordners /store/templates_c, weshalb dann die von Rolf gepostete Meldung geschmissen wird. Lösche ich anschließend alle Dateien und installiere die Serverkomponenten mit PHP per FastCGI oder auch CGI neu, funktioniert nach Wiederherstellung der gesicherten Apache Seite wieder alles wie gewünscht. Ich kann Bilder hochladen und die Seite wird korrekt angezeigt. (Gerne, erstelle ich einen Webhosting-Zugang für dich.)


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersicht & Support für Shop 10 + Pro Web 3)

#14

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

@Paulemann:

PHP 5.4.40 mit "Apache als Modul" oder mit "Apache via FPM/FastCGI"?

Poste mal bitte den folgenden Screenshot aus Deinem Account sowie die Links zu den PHP-Infos.

 Aktuelle PHP-Versionen bei All-Inkl.com

Die Links findest Du hinter den von mir rot markierten PHP-Angaben. Ich würde die gerne mal einsehen und Punkt für Punkt mit meinen vergleichen.

Ein Einzelfall bzw. -problem kann es eigentlich nicht sein, da der Fehler ja ebenfalls bei Rolf (lancair) auftritt. Außerdem existiert das Problem auch erst seit Pro Web Build 1540.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#15

Paulemann

Hero  (746 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.webdesign-bf.de

Bitte schön....

 

 


Gruß

Paulemann

Webdesign-BF - Projektbetreuung und ein wenig mehr...

#16

Paulemann

Hero  (746 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.webdesign-bf.de

Ich habe keine Einstellungen weiterhin vorgenommen.

Die PHP Info findest Du hier.


Gruß

Paulemann

Webdesign-BF - Projektbetreuung und ein wenig mehr...

#17

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

@Thomas:

Mit "Apache als Modul" konfiguriert (Standard bei All-Inkl.com) bekomme ich es seit Build 1540 generell nicht mehr hin. Der Upload von Bildern schlägt hiermit grundsätzlich fehl, auch nach einer völlig frischen Installation in einen leeren Ordner und Wiederherstellung der vollständigen Sicherung meines Projektes via Project Central.

Dein Hinweis, einmal von Null auf (also wieder in einen leeren Ordner) alles per "Apache via FPM/FastCGI" zu erledigen, hat jetzt zum Erfolg geführt. Dafür meinen ganz herzlichen Dank!

Das mit dem Benutzer www-data bei der Modul-Option ist mir natürlich bekannt und ich hatte daher auch jeweils immer die Besitzrechte der Dateien rekursiv angepaßt (im Backend von All-Inkl.com ist dies sehr einfach möglich), wenn ich wegen des Upload-Fehlers testweise mal umgestellt habe. Ebenfalls habe ich immer den Pro Web Cache deaktiviert (in der ngconfig.php DebugMode=true gesetzt). Trotzdem funktionierte die Website per "Apache via FPM/FastCGI" dann nicht. Das mag jedoch noch irgendeine andere Ursache gehabt haben, welche auch immer...

Es bleibt nun weiterhin das Problem, daß die Standard-Einstellung "Apache als Modul" bei mir mit Build 1540 und 1550 im Gegensatz zu früher (Build 1520, 1510 und 1500) nicht mehr nutzbar ist. Der Bilder-Upload ist bei mir damit unter PHP 5.5.24 (andere PHP-Versionen stehen mit dieser Option nicht zur Verfügung) nicht mehr möglich.


@Paulemann:

Du hast wohl ein älteres Paket, in welchem PHP 5.4.40 mit "Apache als Modul" Standard ist. Ich habe keine Ahnung, warum das damit geht und bei mir unter PHP 5.5.24 nicht. Trotzdem danke für Deine Mühen!

Die Hauptsache ist, daß ich jetzt wieder normal mit Pro Web arbeiten kann. Nun eben via FastCGI anstatt per Modul.


@Rolf:

Wie sieht dies bei Dir aus? Welchen Provider nutzt Du? Welche PHP-Version? Wie läuft Apache? Hast Du die Möglichkeit wie ich, die Sachen umzustellen?

Desweiteren: Hast Du mal die serverseitigen Systemvoraussetzungen überprüft? Ist allow_url_fopen = On, also aktiviert?


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#18

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Hallo Volker,

die Seite ist schon seit NG bei Internet24 online. Das Problem ist tatsächlich erst seit 1540 aufgetreten


Viele Grüße Rolf   

#19

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Du hast jetzt genau eine von sechs gestellten Fragen beantwortet, Rolf.

Hilfreich wäre auch in Deinem Fall mal eine PHP-Info.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#20

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

ja ja, ich weis. Ist doch nicht meine Seite und ich habe habe noch keinen Zugriff auf den Server. Ich arbeite dran smile_sleeping_16.png


Viele Grüße Rolf   

#21

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Datenbank Version 5.4.20  könnte aber glaub ich auf 5.5.8 gehen


Viele Grüße Rolf   


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »lancair« (02.07.2015, 18:22)
#22

harlekin8

Experte  (308 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://jrr.harlekin8.de

#23

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

das 1550 geht bei allen anderen Seiten, nur bei Internet24 nicht. Nehme mal an das 1550 und Internet24 nicht zusammen passen smile_confused_16.png


Viele Grüße Rolf   

#24

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Rolf, schaue Dir bitte nochmal den letzten an Dich persönlich gerichteten Teil meines Beitrags #17 an. Du hast (bis auf eine) meine Fragen immer noch nicht beantwortet (nach der Datenbankversion hatte ich übrigens gar nicht gefragt). Ich wüßte daher jetzt nicht wie man Dir hier helfen könnte, obwohl ich dies gerne würde...


Vielleicht ist es auch das beste, Du eröffnest ein Ticket beim Siquando-Support mit direktem Verweis auf dieses Forum-Thema. Bei meinem bis dato auf "Apache als Modul" konfiguriertem Projekt ist es wie gesagt ebenfalls reproduzierbar, daß der Bilder-Upload ab Pro Web Build 1540 nicht mehr funktioniert. Nach Änderung auf "Apache via CGI" (sowie Änderung aller in diesem Zusammenhang ebenfalls zwingend notwendigen Maßnahmen - siehe ebenfalls Beitrag #17, diesmal erster Teil) funktioniert das ganze bei mir nun jedoch wieder.

Der Fehler, den Du hast (und ich hatte) existiert ja noch immer, wenn man eine gewisse PHP/Apache Konfiguration (auf Modul-Basis) im Zusammenspiel mit Pro Web Build 1540 oder 1550 nutzt. Und dies sollte mit dem kommenden Update unbedingt behoben werden.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#25

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

Ja Volker, ich weis, aber ich finde auf den ihren Server nix. Ich stell mich sicher mal wieder zu blöd an. Wenn du möchtest, kann ich dir ja die Zugangsdaten mal zusenden


Viele Grüße Rolf   

#26

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Kannst Du machen. Dazu benötige ich neben den FTP-Zugangsdaten aber auch die zum Backend des Providers um zu prüfen, ob es alternative PHP/Apache Varianten einzustellen gibt. Und natürlich ebenfalls die Pro Web Zugangsdaten.

Ich schaue dann heute im Laufe des Tages mal da hinein. Kann aber später werden, u.U. auch abends.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#27

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Rolf, auf dem Server ist nichts zu machen. Er unterstützt zwar PHP 5.3, 5.4 und 5.5 (CGI/FastCGI), aber kein allow_url_fopen. Dies ist auf "Off" gestellt ("On" ist zwingend erforderlich). Dies hatte ich Dich oben bereits explizit gefragt.

http://www.gp-info.de/info.php


Frage mal den Provider, ob er dies aktivieren kann. Ansonsten kannst Du das Pro Web Projekt auf diesem Server auf deutsch gesagt knicken.


Siquando ist in Deinem Fall definitiv unschuldig.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#28

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

erstmal vielen Dank, Volker. Du hast ja erstmal recht. Ich hatte dir aber auch gesagt das ich nicht weis wo das steht bzw. nix gefunden habe. Das man das mit  **.info.php findet wuste ich nicht. Entschuldige bitte meine unwissenheit.

Es stellt sich mir nun nur die Frage, warum ist es bis zum letzten Update von Web Pro gegangen ist ?

Egal, da werde ich die neuen Bilder über FTP hochladen smile_confused_16.png


Viele Grüße Rolf   

#29

Volker W.

Administrator  (7278 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Die Datei info.php habe ich per FTP hochgeladen. Der Inhalt der Datei ist der folgende:

<?php phpinfo(); ?>


Das wird Zufall gewesen sein. Mit an Sicherheit grenzender Wahrscheinlichkeit war allow_url_fopen auf dem Server bis vor einiger Zeit aktiviert, also "On".

Bilder grundsätzlich nur via FTP hochzuladen und per HTML-Clip zu implementieren, kann aber doch jetzt nicht Deine generelle Lösung sein. Bitte den Provider um Aktivierung von allow_url_fopen bzw. wechlse den Provider, falls dies nicht möglich ist. Andernfalls kann man mit Pro Web darauf wirklich nicht ernsthaft und produktiv arbeiten. Es werden definitiv auch noch weitere Fehler auftreten in diesem Zusammenhang.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#30

lancair

As  (101 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.flugzeugbau.info

ok, danke Volker, werde die morgen mal anrufen.


Viele Grüße Rolf   

2415 Aufrufe | 33 Beiträge