#1

Grisu12349

As  (178 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.feuerwehr-fanshop.de

Aufmacher verlinkt falsch

Hallo,

ich habe gerade folgenden Fehler in Abhängigkeit mit unterschiedlichen Browsern festgestellt:

In der Siquando-Voransicht funktioniert es richtig.
Im Microsoft Internet-Explorer funktioniert es auch richtig (Bild 11)

In Microsoft-Edge und in Google-Chrome verlinkt es falsch ! (Bild 12)


Ich habe im rechten Seitenteil einen Aufmacher mit Ordnern einer bestimmten Ebene mit Unterordnern in der Produktseiten liegen.
Befinde ich mich auf einer dieser Produkt-Seiten und klicke im Aufmacher den selben Ordner an in der sich das Produkt befindet, so wird in Edge und Chrome die Produktseite verlinkt, in der ich mich befinde.
Jedoch sollte, und so ist es in der Voransicht und auch im Internet-Explorer, der Ordner mit den Produkten angezeigt werden.

Ich habe diesen Fehler schon bei Siquando gemeldet.

Ihr solltet vorsichtig sein und überprüfen, wenn ihr einen Aufmacher mit Inhalten von Ordner (Unterordner) einsetzt, dass dieser auch zu den gewünschten Stellen verlinkt.

 

Einstellungen :

Bild%2013.jpg

 

In Internetexplorer und Voransicht :

Bild%2011.jpg

 

In Chrome und Edge:

Bild%2010.jpg

#2

Rubin

Mitglied  (45 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.elfenfee.de

Danke für den Tipp.

#3

Grisu12349

As  (178 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.feuerwehr-fanshop.de

Habe gerade auch festgestellt, dass an der selben Stelle ein manueller Textlink zu einem (Unter)Verzeichnis ebenfalls falsch verlinkt.

Also gibt es hierzu ad hok nur 2 Lösungen:

Entweder den Aufmacher mit den jeweiligen Index-Seiten der Unterverzeichnisse manuell zusammenzustellen,
oder als Textlinks jeweils die Indexseiten zu verlinken.

Wobei dann aber jeweils zu den Indexseiten (.../Textilien/index.html) und nicht zu den Verzeichnissen (.../Textilien/) verlinkt wird.


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »Grisu12349« (27.08.2020, 15:44)
#4

Grisu12349

As  (178 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.feuerwehr-fanshop.de

Ich hatte den Fehler vom Aufmacher bei Siquando gemeldet bzw. einen Fall aufgemacht.

Nach stundenlange Erklärungen... kam dann folgendes zum Ergebnis :

2020-09-02 11:04 Support hat eine Nachricht geschrieben.



Wir haben uns Ihr Projekt angesehen.

In der Voransicht funktioniert der Aufmacher ordnungsgemäß, allerdings nicht im Webbrowser.

Ursache kann sein, dass der Cache vom Webserver nicht erneuert wird oder zu selten oder das mod rewrite funktioniert auf dem Webserver nicht richtig.

Bitte sprechen Sie mit dem Provider.

Zudem haben wir festgestellt, dass Sie ein Fremddesign Bootstrap verwenden.
Leider können wir für Fremddesigns keinen Support leisten.

In unseren Tests auf unseren Servern funktioniert der Aufmacher einwandfrei.

-------------------------------------------------------------------------------------------------------------------------------------

1. Ist der Fehler unabhängig vom Design.
2. Wollte ich keinen Support zu dem Design, sondern zum Aufmacher.
3. Wenn das an meinem Provider liegen sollte, dann werden auch andere damit Probleme bekommen, bzw. erschließt sich für mich dann, dass es vielleicht programmiertechnisch nicht optimal zu sein scheint.

 

Irgendwie entsteht mir der Eindruck, dass man nach Auswegen sucht, sich darum kümmern zu müssen (Design / Provider).

 

Also wer sonst noch den gleichen Fehler feststellen sollte, bitte an Siquando melden.


Dieser Beitrag wurde bereits 3 mal bearbeitet, zuletzt von »Grisu12349« (02.09.2020, 13:52)
#5

Grisu12349

As  (178 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.feuerwehr-fanshop.de

Ursache kann sein, dass der Cache vom Webserver nicht erneuert wird oder zu selten oder das mod rewrite funktioniert auf dem Webserver nicht richtig.

 

So, ich habe soeben mit dem technischen Service meines Providers gesprochen und folgendes zu Antwort bekommen :
Das mod rewrite funktioniert einwandfrei.
Wie oft der Cache geleert oder erneuert wird, ist von der Anwendung abhängig, die dort läuft, also sprich von der Siquando-Software.

Wie ich schon vermutet habe, liegt es an einem Fehler in der Siquando-Software.
Alle anderen Links funktionieren ja auch einwandfrei, nur eben der Link nicht, in dessen Verzeichnis ich auf einer Seite bin.
Sowohl beim Aufmacher, als auch beim Textlink wird dieses falsch verlinkt und bleibt auf der Seite, auf der man sich gerade befindet.
Wie ich schon vermutete, hat das nichts mit meinem Provider zu tun.

Für mich bleibt also erstmal nichts anderes übrig, als die Aufmacher an der Stelle manuell zu den jeweiligen Index-Seiten zu erstellen.

 

#6

Rubin

Mitglied  (45 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.elfenfee.de

Hi,

dann ist mein Weg statt auf Automatismen zu setzen offenbar der Richtige.

Ich lege Aufmacher immer manuell an und kann keine Probleme feststellen.

VG

#7

Grisu12349

As  (178 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.feuerwehr-fanshop.de

Hallo Rubin,

Du wirst das bei dir wahrscheinlich auch nicht feststellen, da Du keinen rechten oder linken Bereich verwendest, in dem Du einen Aufmacher hast.
Der Fehler ist nur in der speziellen Konstellation, wie ich das habe (siehe Bilder oben).

 

Meine Aufmacher in den Zwischenebenen habe ich auch mühevoll von Hand zusammengebaut, aber das hat eher den Hintergrund, dass es den normalen Aufmacher nicht in der Art gibt, wie es den Produktaufmacher gibt, bei dem man alles Frei definieren kann, wie z.B. Schriften usw.

#8

Grisu12349

As  (178 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.feuerwehr-fanshop.de

Hallo,

wir sind da mal wieder ein Stückchen weiter in dem speziellen Aufmacher-Problem.
Ich habe das mit dem mod-rewrite ausprobiert, und daran liegt es definitiv nicht.
Das habe ich in meinem Support-Fall bei Siquando auch so mitgeteilt und bekam erfreulicherweise eine weitere interessante Antwort:

Die Vanity-URLs sorgen dafür, dass im Shop nur einfache und klare URLs zu sehen sind.

Sobald diese Funktion aktiviert wird, verwendet der Shop as Modul "mod_rewrite" und dazugehörigen .htaccess-Dateien.

In Ihrem Shop verwenden Sie zudem Fremddesign, wahrscheinlich ist es ein Karow-Design.

Einige Designs haben früher recht tief in Quellcode eingegriffen, dies kann dann Seiteneffekte auslösen, die nur schwer zu klären sind. Deshalb verfällt auch der Supportanspruch sobald Sie ein Fremddesign verwenden.

Sie könnte das Fremddesign komplett deinstallieren und statt dessen eines unserer Designs verwenden, damit wir diesen Einfluss ausschalten können.

Es gibt bei einem Server verschiedene Cache-Mechanismen - auch der Pro Shop baut einen einen Cache auf. Der Cache wir beim ändern einer Seite verworfen und neu aufgebaut, sobald jemand die Seite im Web aufruft.

Mehr Infos zum Cache-Mechanismus eines Apache Servers finden Sie hier.
https://www.tecchannel.de/a/erweiterte-apache-konfiguration,402259,5


Was sagt mir diese Antwort nun...
Ich werde das mal mit einem anderen Design ausprobieren.
Das mit dem Cache-Mechanismus geht mir doch ein wenig zu tief in die Materie und da habe ich keine Ahnung von (davon aber jede Menge :-P )

Sollte der Fehler mit einem original Siquando-Design dann behoben sein, dann werde ich euch entsprechend informieren.

Zudem bin ich ohnehin am überlegen, ob ich nicht doch besser zu einem original Design wechseln sollte. Zumindest erhält man dann entsprechenden Support bei Siquando.
Verwendet man (wie ich) z.B. ein Karow-Design, dann hat man seit neuestem überhaupt keinen Support mehr, da er weder auf Emails, Formulare seiner Homepage, noch auf persönliche Nachrichten hier im Forum Antwortet.
Einzige Antwort die ich bekam, dass er keine Zeit hat. Leider aber nicht, wann er wieder Zeit haben wird und wann entsprechend Fehler und Wünsche bearbeitet werden.
Also ohnehin ein Grund und auf die Antwort des Siquando-Supports ein Grund mehr, auf solche Fremdsachen zu verzichten.

254 Aufrufe | 8 Beiträge