#1

KPC1504

Neuling  (5 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.peck-consulting.de

Testumgebung für Siquando Pro 8 mittels Apache2, MariaDB und ProFtp auf Raspberry PI4

Liebes Forum,

zur Zeit teste ich meine Webseiten vor der Veröffentlichung auf einer XAMPP Installation unter Windows 11. Nun plane ich das ganze auf einem Raspberry PI4 unter Raspberry PI OSLite umzusetzen. Die Installation läuft bereits mit einem Apache2, PHP 8.2, MariaDB sowie einem ProFtp Server. Die Anbindung an Siquando Pro 8 funktioniert, das Projekt wird korrekt erstellt und auf den Raspberry PI übertragen.

Die WebSite funktioniert von der Struktur, Navigation sowie Darstellung der Elemente. Es werden allerdings keine Bilder auf der Website angezeigt, weder die Bilder aus dem Design noch Bilder die individuell in Absätzen oder sonstigen Elementen eingefügt wurden. 

Jetzt meine Frage an das Forum, wer hat Erfahrung mit diesem Thema und betreibt eventuell sogar eine entsprechende / ähnliche Installation? Für Tipps bzgl. möglicher Fehlerquellen sowie Konfigurationshinweise wäre ich dankbar.


An dieser Stelle wünsche ich dann noch allen hier im Forum einen guten Start ins Jahr 2024 


Vielen Dank für eventuelle Tipps und Hilfe

Klaus

#2

Volker W.

Administrator  (7786 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

#3

KPC1504

Neuling  (5 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.peck-consulting.de

Hallo Volker,

danke für Deinen Hinweis, die GD Library ist aktiviert und auch aktuell. Die Konfiguration auf dem RasPI entspricht den serverseitigen Anforderungen von Siquando. Ich habe das über PHPinfo geprüft. 

Vielleicht noch etwas zur Ergänzung / Beschreibung des Problems. Wenn ich auf dem RasPi eine eigene simple WebSite mit einer index.php erstelle und darin eine Bild anzeigen lasse funktioniert alles.

Das Problem mit Siquando Pro8 ist das der Server mir meldet das das Bild nicht vorhanden sei. Wenn ich mir das auf dem RasPi anschaue sind die Bilder in den statischen Verzeichnissen des Layouts vorhanden. Es sieht so aus als geht bei der dynamischen Erstellung des Seiteninhalts etwas schief. Es gibt in den Verzeichnissen der Webseite auf der obersten Ebene ein Verzeichnis "Store\..." mit weiteren Unterverzeichnissen. Dort liegen dann in verschiedenen Unterzeichnissen die Bilder der WebSite. Hier habe ich einen Unterschied zwischen der XAMPP und der RasPi Installation ausmachen können. In der XAMPP Installation ist hier eine zusätzliche Datei zu finden diese Datei web.xxxx.jgp.w1368.h466 (xxx ist der Name des jeweiligen Bildes) fehlt auf dem RasPi. Ebenfalls ist mir aufgefallen das in der Datenbank die Tabelle spq_url_cache auf dem RasPi leer ist, in der XAMPP Datenbank steht der der ein Link zum jeweiligen letzten angezeigten Bild. Ich werde also weiter forschen müssen, eventuell hat ja hier mit Forum jemand ein RasP Installation am laufen.


Gruß und nochmals vielen Dank für die Info.

#4

Volker W.

Administrator  (7786 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

#5

KPC1504

Neuling  (5 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.peck-consulting.de

Das Problem besteht nach der Änderung weiterhin.

Viele Grüße

Klaus

#6

Volker W.

Administrator  (7786 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Insofern das wirklich so ist, wie Du sagst, bleibt mir abschließend nur noch der Tip zur Betätigung von Strg+F5 bei geöffnetem Browserfenster, um den Browser zum expliziten Neuladen der Seite zu zwingen.

Wenn auch das nicht zum Erfolg führt, habe ich spontan keine weitere Idee mehr. In dem Fall solltest Du mal alle sonstigen Systemvoraussetzungen prüfen. Hast Du die php.ini schonmal inhaltlich auf alles mögliche durchleuchtet?


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#7

KPC1504

Neuling  (5 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.peck-consulting.de

Ich habe alle Systemvoraussetzungen geprüft, die passen. Laut PHPinfo ist alles geforderte Vorhanden, Die PHP.ini habe ich bereits mehrfach durchforscht, auch keine Auffälligkeiten gefunden. Das Error Log von PHP habe ich aktiviert, zeigt ebenfalls keine Fehler. Im Browser Entwicklungsmodus sehe ich das der Aufruf zur Darstellung des Bildes mit der besagten Fehlermeldung schiefgeht, markierte Zeile unten. 

mceclip0.png


Ich habe mittlerweile auch bei Siquando ein Support Ticket eröffnet. Allerdings war die Antwort fast schon wie zu erwarten, für Server sieht man sich nicht zuständig, man hat das Ticket dann mit dieser Antwort auch gleich Supportseitig geschlossen.

Ich werde das Projekt wohl mangels vernünftiger Testmöglichkeiten nicht weiterverfolgen, das kostet nur unnötig Zeit. Werde also dann meinen XAMPP für die Tests weiterhin nutzen.


An dieser Stelle trotzdem noch einmal Danke für Deine Tipps und Anregungen zur Problemlösung.

Gruß

Klaus

#8

MuggelClan

Forum-Sponsor  (790 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Hallo Klaus,

hast du auch mal die FTP-Ordnerrechte überprüft? Falls nicht schau mal und setze diese mal Testweise hoch. Das ist nur mal so eine Idee von mir.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 

#9

MuggelClan

Forum-Sponsor  (790 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Ergänzung:

Wenn die FTP-Ordnerrechte erhöht worden sind (z.B. 755 oder 777), dann könnte es auch sinnvoll sein nochmal über ProjectCentral auf "Installieren oder aktualisieren" zu klicken und dann mit Hacken "Neuinstallation der Komponenten erzwingen" durchzuführen. Dann sollten auch die von dir fehlenden Bilder eventuell installiert werden.

Bzgl. ./images/pictures/layoutpictures/cetera/ss21027.jpg
Schau mal auch dann nach, ob das Bild auch tatsächlich im direkt über die Adresszeile des Webbrowser aufrufbar ist:
http://domain.de/images/pictures/layoutpictures/cetera/ss21027.jpg

Dann ist diese auch vorhanden und hat meiner Meinung mit den Zugriffrechte der Ordner zu tun.
Vergesse nicht bei Rechtevergabe die Unterordner mit einzubeziehen.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 

#10

KPC1504

Neuling  (5 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.peck-consulting.de

Die FTP Ordnerrechte hatte ich schon auf 777 gesetzt, allerdings auch ohne Erfolg.

In der Zwischenzeit habe ich es doch entgegen meiner vorherigen Ankündigung nicht ganz lassen können und weiter geforscht und bin dabei fündig geworden. 

Der Ordner http://domain.de/images/pictures/layoutpictures/cetera/ existiert nicht. Der Pfad endet bei /pictures, dort gibt es in der XAMPP Installation noch eine ..htaccess mit einer RewriteRule. Diese Information hat mich auf die Spur gebracht. Der eigentliche Bildzugriff erfolgt über eine RewriteRule.

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^(.*)$ /domain.de/images/index.php?ngq=$1 [B,QSA,L]
</IfModule>

Letztendlich war auf dem RasPi in der apache2.conf das AllowOverride für das /var/www Verzeichnis auf None und somit defacto abgeschaltet. Damit war keine Auflösung des Zugriffs mittels rewrite möglich. Ich war fälschlicherweise davon ausgegangen das mit 'a2enmod rewrite' das Rewrite generell eingeschaltet sei. Den Teil in der apache2.conf hatte ich nicht auf dem Schirm.

Mit der nachfolgenden Änderung in der apache2.conf funktioniert es.

<Directory /var/www/>

Options Indexes FollowSymLinks

AllowOverride All

Require all granted

</Directory>


Mit freundlichen Grüßen, und nochmaligem Dank an alle Supporter

Klaus

#11

Volker W.

Administrator  (7786 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

692 Aufrufe | 11 Beiträge