#1

inselpirat

Routinier  (496 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.ameland-tips.de

Neue Seite auf den Server spielen

 

Moin zusammen,

 

ich habe es geschafft und unsere Seite jetzt in ProWeb erstellt. Natürlich habe ich das erst einmal alles unter einer Subdomain erstellt und geprüft. Läuft.

Jetzt habe ich mir gedacht, ich ändere einfach die Daten wo ProWeb erstellt werden soll, also eine Datenbank erstellt, die Domain auf php 8.2 erstellt und das Projekt veröffentlicht.

Das war aber wohl nichts, denn ausser der Startseite (allerdings nackt) sehe ich gar nichts.

Frage daher, muss der Ordner leer sein wenn man die Daten überspielt - oder macht es nichts aus, wenn die alte Seite mit web12 erstellt, noch in dem Ordner vorhanden ist??

Danke für Eure Hilfe

Michael

#2

W2D Fan

Co-Administratorin  (4637 Punkte)  ·   weiblich  ·   Niederlande  ·   Nachricht senden

1. Mache bitte nicht der Fehler aller Fehler! Der Ordner soll definitiv leer sein, das haben wir schon gefühlt 1000 Mal gesagt wenn nicht öfter 😉

2. Wie du die Seite online bringst wird sehr gut erklärt im Tutorial_2_produktiv_auf_ng_umschalten.pdf welches du im Files-Bereich herunter laden kannst


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich. Deshalb halte ich ein "Dankeschön", nachdem jemandem geholfen wurde, für überaus angebracht und höflich.

#3

inselpirat

Routinier  (496 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.ameland-tips.de

Danke Marjorie, das hatte ich mir auch schon so gedacht, installiere jetzt in leerem Ordner und füge dann via filezilla die Ordner zusätzlich auf die Bezug genommen wird.

Das Pdf werde ich mir gleich mal runter laden und studieren.

 

VG

Michael

 

#4

MuggelClan

Forum-Sponsor  (943 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Hallo Michael,

du musst nicht die selben Ordner wie im Turtorial erstellen, sehe es als Beispiel. 

Wichtig ist, dass du ProWeb in einem eigenen leeren Ordner erstellst und nicht in den Ordner von der klassischen Web-Version. Das gilt auch für die Domains. 


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 

#5

MuggelClan

Forum-Sponsor  (943 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Zitat:

Thomas,

das hatte ich schon alles durch, lief auch, bis eben auf die externen scripts.

Danke für deine Rückmeldung.

- inselpirat

 

Du musst berücksichtigen, dass die Seiten in ProWeb aus der Datenbank generiert wird und nicht auf dem Server vorhanden sind.

D.h. Verlinkungen auf nicht vorhandene PHP-Seiten funktionieren somit nicht.

Daher müssen die Seiten entsprechend im Windows-Client angelegt werden und dort der Code eingetragen werden.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 

#6

inselpirat

Routinier  (496 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.ameland-tips.de

Thomas,

 

du kannst mir glauben das ich so ein wenig auch weiss was ich machen muss, ich arbeite seit mit web to Date 1.0 bis heute web 12 mit der Software und habe dabei etwas gelernt.

Natürlich habe ich die Seiten auch versucht direkt anzusprechen, also die entsprechenden Ordner und Dateien händisch ins Verzeichnis kopiert, danach die Verlinkungen direkt angelegt.

Trotzdem funktionieren manche Dinge eben nicht - ein Beispiel: eine Datei auf die verlinkt werden soll liegt in der 3.ten Ebene im Hauptverzeichnis, also bisher ../../../abc.php

Nach der Erstellung des Projektes funktioniert das Ganze nicht, nach langem Versuchen funktioniert dann plötzlich abc.php ??

Belassen wir es dabei, es wird nach der Ursache und den Lösungen gesucht und sicher auch irgendwann gefunden, vorher wird mein Projekt nicht umgestellt.

Die externen Unterseiten werden nach und nach umgestellt.

VG

878 Aufrufe | 6 Beiträge