#1

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

Hallo,

mein Problem betrifft Seiten in Chrome und Android. Mit IOS, Firefox und IE ist alles bestens. 

Es geht um die Homepage https://www.kombireise.eu/. Diese wurde von Web 10 konvertiert. Eine zweite Homepage mit Konvertierung der gleichen Ursprungsseite ist hier: https://www.kombi-reise.eu/. Diese benutze ich zum Testen und arbeite weniger intensiv mit dieser Test-Homepage.

Die Homepage https://www.kombireise.eu/ ist auf der Plattform www.wao.io (Cloudserver) gehostet. wao.io komprimiert die Bilder von 4,5 GB auf 2,7 GB.

Die Bilder sind zusätzlich mit www.compressor.io optimiert. Ein Lazy Loading ist aktiviert. Die Website-Eigenschaft Bildqualität ist auf 75 % eingestellt. 

Je mehr ich die Seiten in der Hauptseite neu anpasse, umstelle und die kleinen Bilder durch größere Bilder ersetze, umso mehr Bilder werden nicht mehr geladen, siehe hier: https://www.kombireise.eu/online-buchen/. Es betrifft die Aufmacher-Bilder und auch Text/Bild-Splits.

Bei der Kategorie-Seite https://www.kombireise.eu/dubai/ fehlt jetzt z. B. das Bild von https://www.kombireise.eu/dubai/dubai-sri-lanka/. Nur hier hatte ich das Foto ausgetauscht. Es fehlt im Aufmacher.

Auf der Seite https://www.kombireise.eu/kreuzfahrten/aida-kreuzfahrt/ habe ich nichts gemacht, trotzdem fehlen die Fotos.

Ich hatte den bezahlten Support von Siquando gebeten, mir zu helfen. Dort wurde mir gesagt, das wäre ein Problem der neuen Chrome Engine. Auch andere Kunden hätten solche Ausfälle. Ich solle mich an Google wenden. Das kann aber nicht sein, sonst wären meine übrigen Homepages ebenso betroffen.

Zwischenzeitlich habe ich mehrmals die Browserdaten gelöscht, Inkognito-Modus u. a. probiert, den Server gewechselt (zurück zum klassischen Business-Server). Es hat nichts genützt.

Hat jemand eine Idee, was den Fehler auslösen könnte? 

Angenehmes Wochenende wünscht

Gabriele 

 

 


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »jurebu« (17.10.2020, 23:11)
#2

deekay

Forum-Sponsor  (339 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.lippe-event.de

Ich muss ehrlich sagen, dass ich aus Deiner Seite nicht ganz schlau werde. Der Quelltext ist völlig uberfrachtet, wirkt wirr und die Seiten scheinen nur aus fremden Inhalten zu bestehen?

#3

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

Das ist der wirre Content eines dynamischen CMS. Ich kann nur warnen! Warte die Antwort von Google ab und kehre dann mit 99 % Wahrscheinlichkeit wieder zu Web 10 zurück. Der Quelltext ist so unübersichtlich. Ich schleppe jetzt alle Bilder mit und bin bei 4,5 GB trotz x-maliger Kompression. Das ist doch Wahnsinn. Dazu die vielen Probleme in Lighthouse, Critical Path, DOM etc. Mehr Lehrgeld muss ich nicht zahlen. So toll wie das CMS für Cluster Pages, Siloing etc. ist, so nachteilig ist die Performance. Dazu die fehlenden Bilder. Ich bin geheilt!

#4

deekay

Forum-Sponsor  (339 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.lippe-event.de

Bei anderen Pro-Webseiten sieht der Quelltext aufgeräumt aus. Ist also erstmal nicht das Problem von Siquando

#5

alter

Forum-Sponsor  (366 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://www.petrollampen-shop.ch

ja die Bilder werden teilweise auch nicht in Edge geladen. Ich sehe das Ganze aber auch ähnlich wie deekay, dass liegt nicht an Siquando


viele Grüsse René

#6

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

Es kommt daher, dass ich die Funktion "HTML und CSS-Code komprimieren" gewählt habe. Diese Funktion entfernt alle Leerzeichen und überflüssige Zeichen, um die Ladezeit zu beschleunigen. Dadurch sieht der Quellcode unübersichtlich aus. Das ändert aber nichts am Problem. Ich werde jetzt das Design Wyntherscharff ausprobieren, weil ich glaube, dass die fehlenden Bilder durch Sumimasen verursacht sind. Jede Änderung auf einer Seite an Bildern oder Texten im Aufmacher oder in Bild/Text-Split führt dazu, dass die Bilder der betreffenden Seite nicht mehr oder unvollständig geladen werden.

#7

alter

Forum-Sponsor  (366 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://www.petrollampen-shop.ch

 was willst Du uns jetzt mit dem Begriff "Sumimasen" mitteilen "etymologische Hintergrund"? 😉


viele Grüsse René

#8

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

"Sumimasen" heißt das Design in Pro Web 5, japanisch "Entschuldigung".

Der Fehler ist gefunden. Er wird durch WebP verursacht.

Siquando hat mir folgende Adressen zur Fehlerbeschreibung gesandt:

Also Finger weg von WebP!!! Es ist schon komisch, dass ausgerechnet Chrome und Android das Google eigene Bildformat WebP nicht laden können.

Trotzdem werde ich das neue Design Wyntherschaff mit meiner Testseite testen und beide Designs mit den neuen Google Core Web Vitals analysieren. Wenn es interessiert, schreibe ich dazu ein paar Zeilen.

 

 

#9

alter

Forum-Sponsor  (366 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://www.petrollampen-shop.ch

ja Entschuldigung heisst es in der ersten Japanisch Stunde bis man mehr erfährt ... 😉
Es ist aber schon so das auch Grosse Fotobearbeitungsprogramme wie Adobe Photoshop mühe mit WebP. 

ja ich Denke es könnte den einen oder anderen im Forum noch interessieren was Du rausfindest


viele Grüsse René

#10

Puntigamer

Eroberer  (57 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden

Es erschließt sich mir gerade nicht, warum WebP für dein Problem verantwortlich sein soll, denn im Quellcode finde ich nur .jpg und .png?

#11

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

Wenn die Funktion WebP in Siquando Web Pro 5 aktiviert ist, werden JPEG-Bilder in unterstützten Browsern verlustfrei über 25 % komprimiert. WebP-Grafiken benötigen dadurch weniger Speicherplatz bei gleicher Bildqualität, und eine Seite wird dadurch wesentlich schneller geladen. 

Der Spezialist in der Google Webmaster Community ist übrigens der Meinung, dass es ein CMS-Problem und nicht ein WebP-Problem ist. Eine der Antworten lautet: "..., denn das verwendete PlugIn ist fehlerhaft programmiert und statt den Fehler zu beheben wurde dir geraten es nicht mehr zu verwenden."

Dass meine Seite jedoch mit IOS und Firefox funktionierte, hat den Spezialisten nicht tangiert. 

Nun, ich bin keine Programmiererin und habe absolut keine Ahnung, wer nun Recht hat. Mir ist es auch egal, da meine Homepage ohne WebP wieder funktioniert, siehe hier: https://www.kombireise.eu/. Mir geht es nur darum, die Leistung zu optimieren, sprich FCP, LCP, CLS zu verbessern. Page Speed Index war gestern. Die Homepage läuft jetzt wieder über den Cloudserver von wao.io, da mein Business-Server viel zu langsam ist.

Wer von den Metriken LCP, FCP, CLS noch nichts gehört hat, kann hier nachlesen: https://developers.google.com/web/tools/lighthouse. Ich benutze übrigens die Chrome Extension.

Wer sich mit der Optimierung der Metriken beschäftigen möchte, wird u. a. hier fündig: https://web.dev/optimize-lcp/

Warum? Google wird ab März 2021 keine Desktop-Seiten mehr indexieren! Mobile Indexing und die Google Core Web Vitals LCP, FCP, CLS werden dann für alle Webseiten zum Standard. 

 


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »jurebu« (19.10.2020, 21:41)
#12

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

 

 

 

Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »jurebu« (20.10.2020, 09:30)
#13

alter

Forum-Sponsor  (366 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://www.petrollampen-shop.ch

Hallo jurebu

ja funktionieren tut es auch auf Edge aber die Bilder sind sehr verschwommen. Also ich selbst setze auch das Plugin Photo Pack Plus ein und habe keinerlei Probleme damit. Allerdings muss ich sagen das ich meine Bilder mittels Photoshop versuche bereits auf eine vernünftige Grösse (ohne resp. mit geringen Verlusten) zu reduzieren

Wenn man im www nachschaut findet man dazu auch folgenden Text:

"WebP ist als reines Bildformat ein Exot

Chrome-Nutzer haben zumindest insofern kein Problem, als das sich Chrome während der Installation als Standardbetrachter für WebP einrichtet, sodass ein Doppelklick auf eine heruntergeladene WebP-Datei zumindest zu einem Ergebnis führt. Andere Nutzer dürften durchaus verdutzt sein, wenn sie ein Bild auf der Festplatte nicht öffnen können."
Ich Denke bei Dir liegt es an der Bildgrösse. Ebenfalls reagieren Apache- und Nginxserver etwas unterschidlich auf die Abfragen. Siquando ist für Apache optimiert

Anstelle des-Plugin Lösung könntest du mit einer Konfigurationsanweisung in der .htaccess dafür sorgen, dass bei Verfügbarkeit eines zu einem Jpg oder Png korrespondierenden WebP-Files eben jenes verwendet werden soll.

Das sähe für Apache so aus:

RewriteEngine On

RewriteCond %{HTTP_ACCEPT} image/webp

RewriteCond %{DOCUMENT_ROOT}/$1.webp -f

RewriteRule ^(wp-content/uploads.+)\.(jpe?g|png)$ $1.webp [T=image/webp,E=accept:1]

Header append Vary Accept env=REDIRECT_accept

AddType image/webp .webp

bei Nginx:

# http config block

map $http_accept $webp_ext {

default "";

"~*webp" ".webp";

}

# server config block

location ~* ^/wp-content/.+\.(png|jpg)$ {

add_header Vary Accept;

try_files $uri$webp_ext $uri =404;

}

Um die Optimierung müsstest du dich bei dieser Lösung natürlich ebenso selber kümmern, wie um die Bereitstellung korrespondierender Dateien.

@sollte die Anweisung tatsächlich von Siquando kommen würde mich dies aufs äusserste Erstaunen. Dann hätten wohl alle welche die Erweiterung von Siquandeo gekauft hätten das gleiche Problem wie Du...


viele Grüsse René

#14

jurebu

Mitglied  (35 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.kombireise.eu

Hallo Rene,

ganz vielen Dank für so viel Mühe. Ich bin nun vorsichtig geworden, denn "...Durch das WebP-Format lässt sich der Pagespeed deutlich erhöhen. Jedoch kann es aufgrund der fehlenden Tools und Kompatibilität zu Problemen führen." 

Die Bilder sind jetzt von 1280 auf 640 verkleinert! Es sieht nun bescheuert aus trotz 100 % Qualität. Werde wieder die größeren Formate nehmen. Danke für den Hinweis. Es sieht nicht nur bei Edge bescheuert aus.

@Ja, der Siquando-Support hat so geraten. Dabei hatte ich ihn zweimal kontaktiert. Der eine meinte, das Problem läge an der neuen Google Engine, auch andere Siquando-Nutzer hätten es. Beim zweiten Mal hatte ich darum gebeten, den Programmierer zu kontaktieren, da ich überzeugt war, dass das Design Sumimasen fehlerbehaftet ist. An WebP hatte ich nie gedacht.Die Aufforderung durch Siquando, WebP abzuschalten, lässt natürlich sehr viele Schlüsse zu. 

Frohes Schaffen!

Gabriele


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »jurebu« (20.10.2020, 10:26)
#15

Merlin2504

Vielfrager  (1255 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden

Die Aufforderung durch Siquando, WebP abzuschalten, lässt natürlich sehr viele Schlüsse zu. 

 Das hat Siquando wirklich empfohlen? Ich kann das gar nicht glauben, zumal sie weiterhin ihr "fehlerbehaftetes" Photopack bewerben und verkaufen.


Ich kann ich hier im Forum niemand direkt kontaktieren, da mein Konto dafür keine Berechtigung hat.
Wer mich erreichen möchte, einfach per Mail: info(at)jahnwerbung.de

#16

alter

Forum-Sponsor  (366 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://www.petrollampen-shop.ch

Hallo Gabriele

wie gesagt ich verwende die Erweiterung ebenfalls und habe WebP aktiviert. Habe Stand heute keine Rückmeldungen das Bilder nicht Sichtbar sein sollen usw.. Daher die Antwort von Siquando ist für mich nicht Nachvollziehbar.

Aber auch bei WebP muss man die Bilder vorher selbst aufbereiten.

Wikipedia beschreibt das folgendermassen:
https://de.wikipedia.org/wiki/WebP


viele Grüsse René

#17

Merlin2504

Vielfrager  (1255 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden

WebP steht trotzdem, vor allem bei Siquando, noch in den Startlöchern. Denkt mal dran, wie lange Siquando gebraucht hat, png Bilder zu integrieren. Dies funktioniert bisher auch nur in der ProVersion. In der Classic Linie, nur durch Zusatzsoftware. Das Photopack wandelt bisher nur jpg Daten in WebP um, png Bilder bleiben png. 😢

Sinnvoller wäre es auch, wenn Siquando endlich sauber programmieren würde und solche Dinge gleich integriert, anstatt hinterher halbfertige Produkte, wie Photopack anzubieten. Ich habe mal versucht WebP Bilder direkt in ProShop zu importieren. Geht wiedermal nicht. Da ich Fotograf bin, möchte ich meine Bilder im Vorfeld für das Web selbst optimieren. 

@Gabriele: Die Tipps von Siquando bezüglich Bilder optimieren und Bildergrößen kannst du vergessen. Ich helfe mir immer in dem ich verschiedene Bildergrößen erstelle und dann teste. Ist ein Riesenaufwand, aber es lohnt sich.


Ich kann ich hier im Forum niemand direkt kontaktieren, da mein Konto dafür keine Berechtigung hat.
Wer mich erreichen möchte, einfach per Mail: info(at)jahnwerbung.de

#18

Thomas

Co-Admin  (2136 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Ich könnte mir gut vorstellen, dass die Verwendung einer aktuelleren PHP-Version (und entsprechend aktuellere Bildmodule wie GDLib) dein Problem beheben könnte.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Shop und Apollon 10 für Siquando Shop, Templateübersicht & Support für Shop 10 + Pro Web 3)

#19

alter

Forum-Sponsor  (366 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://www.petrollampen-shop.ch

wie gesagt ich verwende diese Erweiterung und habe bis zur Stunde keine Probleme feststellen können. Ich selbst verwende PHP 7.3 die Fotos bearbeite ich mit Adobe Photoshop.


viele Grüsse René

#20

Hennes74

Eroberer  (99 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.pimpmychart.com

Hallo zusammen,

über das hier beschriebene Problem bin ich vor einigen Wochen auch gestolpert, nachdem ich WebP testweise aktiviert hatte.
In den Aufmachern hat in Chrome ca. jedes zweite Bild gefehlt.

Die Ursache liegt hier aber nicht bei Siquando, sondern beim Hoster. Zumindest war das bei mir eindeutig der Fall.
Ich habe 2 identische Seiten bei 2 verschiedenen Hostern erstellt. Bei Strato tritt das Problem in Chrome nicht auf, bei IONOS aber schon.

Nach Rücksprache mit IONOS und einigen Tests, wurde mir bestätigt, dass ein Bug in der dort verwendeten Image Library das Problem verursacht.
Das Problem scheint die Dateigröße zu sein. Der WebP-Standard verlangt, dass das erzeugte Bild eine gerade Anzahl von Bytes groß ist.

Mit einem kommenden Update des Betriebssystems bei IONOS soll dort das Problem dann behoben sein.
Die Info kam Ende August, bislang warte ich noch auf das Update...

Gruß

Hennes 

#21

deekay

Forum-Sponsor  (339 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.lippe-event.de

Und hier sieht man mal wieder: Es ist zu einfach , die Schuld gleich an Siquando zu geben

223 Aufrufe | 21 Beiträge