#1

lobo

Grünschnabel  (14 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.oldstamp.de

Fatal error

Mein Shop ist seit gestern nicht mehr erreichbar und ich bekomme stattdessen ein Fehlermeldung:

Fatal error: Uncaught TypeError: mysqli_query(): Argument #1 ($mysql) must be of type mysqli, null given in /homepages/37/d823019575/htdocs/assets/s2dimysql.php:83 Stack trace: #0 /homepages/37/d823019575/htdocs/assets/s2dimysql.php(83): mysqli_query(NULL, 'SHOW TABLES FRO...') #1 /homepages/37/d823019575/htdocs/assets/s2diinit.php(73): dbms->sql_query('SHOW TABLES FRO...') #2 /homepages/37/d823019575/htdocs/assets/s2di.php(16): require('/homepages/37/d...') #3 /homepages/37/d823019575/htdocs/index.php(22): require('/homepages/37/d...') #4 {main} thrown in /homepages/37/d823019575/htdocs/assets/s2dimysql.php on line 83

Weiß nicht wie ich das beheben kann und bitte um schnelle Hilfe von euch.

Gruß Thomas

#2

MuggelClan

Eroberer  (54 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.donaustauf.info

Hallo Thomas,

schau mal bei Deinem Webhosting-Provider ob zufällig die PHP-Version geändert wurde.
Wenn du das selber ändern kannst, dann verwende PHP-Version 7.4, Normalerweise kannst das selber ändern, falls nicht, dann wende dich an dein Webhosting-Anbieter.
Welche PHP-Version wird verwendet?


Mit freundlichen Grüßen

MuggelClan

Web To Date seit 2004, Siquando Web 11, Pro Web 6

#3

alter

Forum-Sponsor  (784 Punkte)  ·   männlich  ·   Schweiz  ·   Nachricht senden
 https://www.petrollampen-shop.ch

Grundsätzlich dürfte die Antwort von MuggelClan passen, was ich jetzt aber nicht weiss, unterstützt Shop 10 schon PHP 7.4. Sollte der Provider gar auf PHP 8.x umgestellt haben, ginge das sicher nicht. Wird auch nicht von Shop11 unterstützt


viele Grüsse René

#4

lobo

Grünschnabel  (14 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.oldstamp.de

Danke für die Antwort. Hat mir sehr geholfen. Hatte beim Provider PHP 7,4 und habe es auf PHP 8,0 umgestellt.

Vielen Dank !

#5

alter

Forum-Sponsor  (784 Punkte)  ·   männlich  ·   Schweiz  ·   Nachricht senden
 https://www.petrollampen-shop.ch

Hallo Thomas
hast Du den proShop6? Mit Shop 10 dürfte das nicht gehen. Deine Webseite ist zumindest immer noch nicht erreichbar, sofern es sich um diesen Link handelt
https://www.oldstamp.de


viele Grüsse René

#6

MuggelClan

Eroberer  (54 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.donaustauf.info

Hallo,

Siquando Shop 10 kann mit PHP-Version 7.3 laut diesem Beitrag umgehen. Die Migration von PHP 7.3 auf PHP 7.4 waren nur kleine Änderungen bzw. Ergänzungen (siehe www.php.net). Falls jedoch PHP bei Shop 10 mit PHP 7.4 Schwierigkeiten machen sollte, dann kann man noch auf PHP 7.3 umstellen. Es ist aber wie immer in dieser Situation ratsam auf Shop 11 oder künftig höhere Version zu wechseln. Da es eventuell vielleicht in diesem Jahr ein neun Shop 12 oder höher geben könnte (das weiß nur SIQUNDO selber), würde ich es erst mal bei Shop 10 mit PHP 7.4 versuchen und dieses Jahr aussitzen. Da Thomas oben schreibt, dass er vorher auch PHP 7.4 laufen hatte, gehe ich davon aus, dass keine Probleme mit dieser Version gab.


Mit freundlichen Grüßen

MuggelClan

Web To Date seit 2004, Siquando Web 11, Pro Web 6

#7

lobo

Grünschnabel  (14 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.oldstamp.de

Hallo das mit PHP 8.0 ging nur einen Moment. Habe alles wieder auf die alte PHP-Version 7.3 zurück gestellt und im Moment läuft die Webseite.

Mit freundlichen Grüssen

#8

Roland 1

Eroberer  (92 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://rswelt.de

Grundsätzlich dürfte die Antwort von MuggelClan passen, was ich jetzt aber nicht weiss, unterstützt Shop 10 schon PHP 7.4. Sollte der Provider gar auf PHP 8.x umgestellt haben, ginge das sicher nicht. Wird auch nicht von Shop11 unterstützt

 Laut Siquando stimmt die Aussage René,

mein Shop 11 läuft auf PHP 8.0 einwandfrei.


Gruß

Roland

#9

alter

Forum-Sponsor  (784 Punkte)  ·   männlich  ·   Schweiz  ·   Nachricht senden
 https://www.petrollampen-shop.ch

Hallo Roland
Danke für die Information, ich hatte Siquando betr. Shop11 und der PHP-Version angefragt. Diesbezüglich bekam ich die Antwort, dass erst PHP7.4 unterstützt würde. Aber ja, die Antworten scheinen je nach Support-Mitarbeiter offenbar verschieden auszufallen 😃

Aber ob das mit PHP 8.0 auch bei Thomas geht? Er hat ja erst Shop10.


viele Grüsse René

197 Aufrufe | 9 Beiträge