#1
Avatar

Unbekannt

Gelöscht

nicht mehr aktiver Gateway

Hallo Zusammen

Ich habe gerade eine Webseite erstellt. Nun wollte ich das Kontakt-Formular mal testen und habe gemerkt, dass der interne Gateway von DATABECKER nicht mehr geht.

Weiss hier jemand einen guten Rat?

Vielen Dank und Grüsse
Patrik

#2

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Zunächst einmal willkommen im Forum! ;-)


web to date 8 verwendet keinen Gateway, der auf einem DATA BECKER Server liegt bzw. lag. Der interne Formular-Gateway arbeitet via PHP-Script auf Deinem eigenen Webserver.

Oder was genau meinst Du?

Ich weiß, daß ganz alte w2d-Versionen (um w2d 4 herum) mal mit einem Gateway-Script arbeiteten, welches auf einem DB-Server lag. Auf w2d 8 trifft dies jedoch definitiv nicht zu.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#3

W2D Fan

Co-Admin  (3261 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Zunächst mal willkommen hier im Forum.

Ich kann dein Problem zumindest mit Version 8S nicht reproduzieren, du sagst ja nicht mit welcher Version du arbeitest. Hast du bei deinem Hoster auch eine Absenderadresse hinterlegt (zB mail@deinedomain.de). Bei viele Hoster ist es Pflicht dies zu tun und hast du alle SPs installiert. Möglich hat dein Hoster eine neue PHP-Version installiert und wenn du nicht zumindest das letzte SP installiert hast, könnte dies ein Problem auslösen.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#4

W2D Fan

Co-Admin  (3261 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Doppelt hält halt besser ;-)


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#5
Avatar

Unbekannt

Gelöscht

Ich benutze W2D8, Build 2377.


Im Formular habe ich diese Auswahl getroffen. Trotzdem geht es nicht.

#6

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Zitat von: W2D Fan

..., du sagst ja nicht mit welcher Version du arbeitest.

Doch, das hat er (im Beitragstitel). ;-)


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#7

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Zitat von: Patrik2015

Trotzdem geht es nicht.

Patrik, kannst Du das Problem bitte etwas genauer beschreiben (mehr Details, Link, Screenshot...)?


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#8

W2D Fan

Co-Admin  (3261 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Das habe ich dann wohl gekonnt ueberlesen Volker ;-)


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#9
Avatar

Unbekannt

Gelöscht

ZwischenablageJPG.jpg

#10

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

Hoi Patrick (aus Deinem Doppel-Posting weiss ich, dass Du ja auch aus der Schweiz bist)

 

Dein Printscreen ist schon ok, sagt aber nichts zu Deinem Fehler aus...

WAS genau funktioniert denn nicht...?

 

Ich persönlich vermute eher, dass Du "CHMOD durchführen" nicht angehakt hast und deswegen keine Schreibrechte hast...???


Gruss

Walti

#11

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Das hilft jetzt nicht so richtig. Poste lieber einen Screenshot der gesamten Formular-Konfiguration.

Auf welcher Seite (bitte mal einen Link) befindet sich das Formular? Hast Du eine Empfänger-Adresse angegeben? Hast Du eine Feedback-Seite angegeben? Unter welcher PHP-Version läuft Dein Webserver?

Usw. usw. ...


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#12

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

@Volker:

...wir sind am Glaskugel reiben...  ;-)


Gruss

Walti

#13
Avatar

Unbekannt

Gelöscht

Ups, ich habe die Files von Hand auf meinen Webserver geladen.

Es könnten also Schreibrechte sein...

#14
Avatar

Unbekannt

Gelöscht

Danke.

Wo finde ich denn die ganze Formular-Konfiguration?

Eine Empfänger-Mailady habe ich auch nicht angegeben.

Ich habe das Projekt von W2D5 importiert. Unter W2D5 lief alles ohne Probleme.

#15

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Ein solch altes Formular wird in w2d 8 nicht funktionieren, zumal wie Du sagst kein Empfänger angegeben ist. Lösche am besten den gesamten Formularabsatz und erstelle ihn vollständig neu. Der Assistent fragt Dich dabei alles notwendige ab.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#16

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Zitat von: Patrik2015

Wo finde ich denn die ganze Formular-Konfiguration?

Eine Empfänger-Mailady habe ich auch nicht angegeben.

Ich habe das Projekt von W2D5 importiert. Unter W2D5 lief alles ohne Probleme.

Zu 1.) Hier:

 Formular-Konfiguration

Zu 2.) Das ist natürlich ein schwerwiegendes Problem. ;-)

Zu 3.) Aus w2d 5 importiert bedeutet aber womöglich inkompatibel. Ich bin mir nicht ganz sicher, ob in w2d 5 evtl. noch der Gateway als Option zur Verfügung stand, welcher auf einem DB-Server lag. Ein solcher Formularabsatz kann mit w2d 8 technisch nicht mehr funktionieren.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#17
Avatar

Unbekannt

Gelöscht

Danke, ich habe ein neues Formular erstellt. Geht immer noch nicht.


Kann es an den Schreibrechten liegen?

#18

Volker W.

Administrator  (7055 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Natürlich kann es an den Schreibrechten liegen. Dazu mußt Du wie Walti schon mitteilte die Option "CHMOD durchführen" aktivieren und Dein Projekt neu veröffentlichen.

Es wäre jedoch weiterhin interessant, wo Dein Formular zu begutachten ist (Link), welche Formular-Einstellungen Du verwendest usw. ...


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#19

Robert

Profi  (115 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden
 http://www.rs-studio.at

Der  original  W2D und Siquando Gateway hat noch immer das Problem das keine Absender Adresse definierbar ist..
Die sollen einmal ihre Hausaufgaben machen.

VG Robert


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Robert« (21.04.2015, 23:42)
#20
Avatar

Unbekannt

Gelöscht

Ich habe ein neues Formular erstellt. Geht leider immer noch nicht.

Die Veröffentlichung mache ich nun auch innerhalb des Programms. Ist die Build 2377 denn überhaupt aktuell?

 

FormNeu.jpg

 

 

#21

Robert

Profi  (115 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden
 http://www.rs-studio.at

Bei welchen Provider bist du den ??

VG Robert

#22
Avatar

Unbekannt

Gelöscht

https://www.hosteurope.ch/

#23
Avatar

Unbekannt

Gelöscht

Auf dem Server läuft PHP 5.3.

#24

Robert

Profi  (115 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden
 http://www.rs-studio.at

https://faq.hosteurope.de/?cpid=11073

 

Host Europe verwendet wie Goneo den Parameter 5 als Absenderadresse, damit ist das original Aiquandoscript dafür unbrauchbar. ab der letzten Version wir die eingetragene Emailadresse als ABsender eingetragen, darum erhälst du nichts.
Dazu müßte das Script angepasst werden.

VG Robert

#25

Robert

Profi  (115 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden
 http://www.rs-studio.at

Du kannst einmal probieren wie auf dieser Seite erklärt im Web Adminbereich eine absender adresse zu definieren.

VG Robert

#26
Avatar

Unbekannt

Gelöscht

Danke Robert!

Wie ist es denn bei diesem Provider?

http://www.hoststar.ch/de/home/home.html?gclid=CNr2m4TwicUCFUP3wgodRW8A6g

 

#27

Robert

Profi  (115 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden
 http://www.rs-studio.at

Die schreiben nichts besonderes, und bieten ein uralt Script an zum Mailversenden. laut diesen würde es auch mit Siquando funktionieren.

Nur das hat leider einen uralt Stand was mich bezüglich diesen Providers stutzig macht. Hast du das mit dem Adminbereich schon probiert ?

VG Robert

#28
Avatar

Unbekannt

Gelöscht

Lieben Dank.

Ich glaube ich zügle die Seite zu Hoststar... Ich habe es gerade getestet. - Dort läuft alles.

Oder hat jemand ein fertiges Script, bei dem ich nur noch die Mailadresse abändern kann?

#29

Robert

Profi  (115 Punkte)  ·   männlich  ·   Österreich  ·    Nachricht senden
 http://www.rs-studio.at

Es sit nur Schade das Siquando da nicht nachbessert.

VG Robert

#30
Avatar

Unbekannt

Gelöscht

Ich habe gerade noch das Script umgeschrieben. Leider geht es nicht.

Ich bekomms leider nicht hin. Wollen wir vielleicht kurz eine TeamViewer-Session machen?

1647 Aufrufe | 45 Beiträge