#1

thomas-w

Neuling  (8 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://vffow.de

Hallo,

ich versuche ein Kontaktformular mit dem Google reCaptcha v2 zu versehen. Sobald ich jedoch den Private und Public Key im Formular hinterlege, kommt es nach dem Absenden zum Fehler "Das Formular konnte nicht abgeschickt werden. Bitte überprüfen und korrigieren Sie die angezeigten Fehler:"

Die Keys habe ich direkt aus dem Google-Konto kopiert, damit da keine Abweichung entsteht. Das Captcha ist auch eine v2 Version. Das Formular habe ich, um Fehler auszuschließen, auf eine eigene Seite gesetzt: https://testsiqu.vffow.de/content/gaestebuch_kontaktformular/kontaktformular/

Wie bekomme ich den Fehler behoben, damit das Formular mit reCaptcha funktioniert?

Für Hilfe und Tipps bereits vielen Dank im Voraus.

Viele Grüße,
Thomas

#2

alter

Forum-Sponsor  (483 Punkte)  ·   männlich  ·   Schweiz  ·   Nachricht senden
 https://www.petrollampen-shop.ch

Hallo Thomas

Du hast in Deinem Kontaktformular ja nur drei Pflichtfelder welche zwingend bedient werden müssen. Das heisst der Fehler müsste von einem der drei generiert werden. Ich habe soeben versucht eine Kontaktanfrage auf Deiner Seite zu generieren und es hat wie Du erwähnt hast den besagten Fehler ausgegeben. Nach der Fehlerangabe habe ich auch Name / Vorname abgefüllt und habe den gleichen Fehler erhalten.

Könnte es sein das Du bei den Einstellungen nicht alle benötigten Angaben eingepflegt hast? Ein weiteres Problem könnte das angewählte Format der Felder sein. Wenn dies nicht stimmt gibt es auch die Fehlermeldung

Viele Grüsse René

@hier noch den Link zu meinem Formular http://petrollampen-shop.ch/proshop/common/info/kontakt.html



 


viele Grüsse René

#3

thomas-w

Neuling  (8 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://vffow.de

Hallo René,

danke für deine Rückmeldung.

Mit den Einstellungen meinst du die "erweiterten Einstellungen" welche beim Kontaktformular hinterlegt werden (Absendermailadresse, captcha-Keys, usw.), oder gibt es noch eine andere Stelle an der etwas eingetragen werden muss?

Die Felder sollten vom Typ her stimmen. Wenn ich die captcha-Keys entferne, kann ich das Formular auch ohne Fehler absenden.

Viele Grüße,
Thomas

#4

thomas-w

Neuling  (8 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://vffow.de

Sorry, ich habs gefunden. Beim Gästebuch steht etwas mehr Info auf der Registerkarte zur Hinterlegung der cptcha-Keys. Auf dem Webserver muss der PHP-PArameter allow_url_fopen auf on (bzw. 1) gesetzt sein, dass war leider nicht der Fall.

#5

alter

Forum-Sponsor  (483 Punkte)  ·   männlich  ·   Schweiz  ·   Nachricht senden
 https://www.petrollampen-shop.ch

Hallo Thomas

gehe davon aus das es jetzt funktioniert? 😃

Gruss René


viele Grüsse René

#6

thomas-w

Neuling  (8 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://vffow.de

ja, jetzt funktioniert es korrekt.

#7

Volker W.

Administrator  (7659 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

#8

HB1909

Grünschnabel  (24 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.holstein-borussen.de

Die PHP-Einstellung allow_url_fopen = on setzt Siquando für Pro Web ja auch voraus.

 Moin moin,

ich habe scheinbar das gleiche Problem, wo kann ich denn diese Einstellung vornehmen?

#9

HB1909

Grünschnabel  (24 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 http://www.holstein-borussen.de

habe "allow_url_fopen = on" in meine .htaccess-Datei gesetzt. Jetzt lädt die Seite gar nicht mehr.

Hat jemand einen Tipp für mich 😕

 

#10

alter

Forum-Sponsor  (483 Punkte)  ·   männlich  ·   Schweiz  ·   Nachricht senden
 https://www.petrollampen-shop.ch

494 Aufrufe | 10 Beiträge