#1

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Funktion fehlt im Menü

Ich nutze Pro Web seit vielen Jahren in größeren Projekten und habe den Pro Shop neu und sauber installiert. Das erste Projekt mit dem Shop ist aber (noch) ein reines Web-Projekt, da ich erst die Inhaltsseiten anlege, bevor ich mich dann mit den Verkaufsseiten beschäftige. Neu angelegt (kein übernommenes Altprojekt). Bewährter, funktionierende Umgebung auf der auch alle anderen Pro Web Projekte einwandfrei funktionieren.

Jetzt fehlt im Pro Shob bei mir die Funktion "Zugriffsschutz", die man ja üblicherweise im Eigenschafts-Kontext der Ordner und im Hauptmenü unter Datei/Zugriffsschutz findet / finden sollte:

Siquando%20ohne%20Zugriffschutz%201.jpg Siquando%20ohne%20Zugriffschutz%202.jpg

 

Der Siquando-Support vermutet eine defekte Installation, die ich aber weitgehendst ausschließen würde, da ich den Pro Shop eben noch einmal neu downgeloadet, installiert und alle Komponenten zwangsweise aktualisiert habe.

Ich vermute dagegen, dass der Siquando Pro Shop diesen Zugriffsschutz -warum auch immer- bei reinen Web-Projekten ohne Shopfunktionalität "vergisst".

Es wäre zur Abgrenzung eine große Hilfe, wenn ein Forums-Mitglied mit Pro Shop und einem reinen Web-Projekt kurz nachschauen könnte, ob dort der Zugriffsschutz ebenfalls fehlt. Mit reinem Web-Projekt meine ich, dass der Shop-Wizzard nicht durchgeführt worden ist und das Projekt damit ohne "Shop-Infrastruktur" bearbeitet wird (von Siquando empfohlen):

Pro%20Shop%20Wizzard.jpg

Herzlichen Dank im Voraus für eine Rückmeldung.

Beste Grüße
Oliver

#2

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Hallo Oliver,

ich kann das von Dir sehr gut dokumentierte (und belegte!) Problem des "verlorenen" Zugriffsschutzes nicht reproduzieren. Ist die Funktion Zugriffsschutz denn initial vorhanden, also bevor Du das Projekt zum reinen Webprojekt machst?


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#3

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Hallo Volker,

das Projekt war nie ein Shop-Projekt. Im Project-Central neu angelegt und dann im Siquando Client wie im Screenshot zu sehen "ohne Shop-Infrastruktur" -wie empfohlen- weitergearbeitet. Neben dem Pro Shop sind sämtliche kaufbaren Module und Designs installiert, inklusive "digitale Güter".

Auf demselben Rechner und Server läuft auch Pro Web 3 mit diversen Projekten, die alle problemlos inklusive Zugriffsschutz funktionieren. Nur das neue und erste Projekt des Pro Shop hat leider (wie in den Screenshots zu sehen) nicht die Menüpunkte oder Eigenschaftsreiter für den "Zugriffsschutz". Der Server ist ebenfalls 100% sauber für Siquando eingerichtet, nutzt PHP 7.2 und funktioniert wie gesagt mit allen Pro Web 3 Projekten problemlos. Auch dieses Pro Shop Projekt funktioniert einwandfrei - bis auf den Zugriffsschutz, den ich aber leider für die weiteren Arbeiten am Projekt dringend brauche.

Auf Anraten des Siquando Supports habe ich den Pro Shop schon komplett neu installiert und alle Komponenten aktualisiert. Jedoch ohne Veränderung. Hätte mich auch gewundert.

Der Siquando-Support hat mir ebenfalls ein "Beweis-Foto" gesendet, dass bei Ihnen der Menüpunkt vorhanden ist. Hilft mir nur leider nicht.
 
Hast Du bei Dir auch die "Digitalen Güter" installiert? Das war die einzige Veränderung. Da kurz hintereinander installiert kann ich nur leider nicht sagen, ob vor der Installation der "Zugriffschutz" da war. Vermutlich nicht. Aber manchmal gibt es ja die merkwürdigsten ZUsammenhänge. Bin derzeit ratlos.

Habe mittlerweile die Shop-Funktionalitäten aktiviert - leider auch danach keine Veränderung.

Beste Grüße

Oliver

#4

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Da die Ursache dieses kuriosen Problems auch mich sehr brennend interessiert, würde ich gerne eine Fernwartung per TeamViewer mit Dir durchführen, um dem Problem auf die Schliche zu kommen. Das Ergebnis wird entweder die Lösung des Problems sein oder die genaue technische Ursache, welcher sich Siquando dann annehmen muß.

Wäre dies OK für Dich und würde es Dir morgen irgendwann zwischen ca. 14:00 und 17:00 Uhr passen? Heute paßt es zeitlich bei mir nicht mehr, denn ich werde ab ca. 14:00 Uhr bis zum Abend unterwegs sein.


Daß der Siquando-Support Dir einen Screenshot schickt, daß es dort funktioniert, ist i.d.T. bemerkenswert. Wem bringt dies etwas?


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#5

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Hallo Volker, 

herzlichen Dank, sehr gerne. Leider geht es dieses Wochenende nicht, da ich verreist bin. Ich leae Deine Nachricht gerade am Smartphone. Ab Montag aber sehr, sehr gerne.

Und ja, Support, der mehr Anstrengungen unternimmt dem Kunden zu zeigen, dass ein Problem bei ihm liegen muss, statt - gerade bei einem neuen Produkt - aktiv nach einer Lösung zu suchen ist wenig hilfreich. Leider ist Siquando da keine Ausnahme.

Bin schon gespannt, ob und was wir gemeinsam per Teamviewer entdecken.

Danke schon einmal vorab und beste Grüße 

Oliver 

#6

Thomas

Co-Admin  (2023 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Ich kann es bestätigen, Oliver ist nicht allein. Ich habe ein Pro Web 3 Projekt geupdatet zu Pro Shop, ohne Shop-Funktionen zu aktivieren und die Zugriffsschutz Option ist NICHT vorhanden. Auch bei einer Neuinstallation scheint das der Fall zu sein.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersicht & Support für Shop 10 + Pro Web 3)

#7

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Hallo Thomas, 

vielen Dank für die Info! Selbst wenn wir noch keine Lösung kennen (ohne dass die Siquando Entwickler sich dessen annehmen - nicht der Support) beruhigt es zumindest, dass es sich bei mir nicht um einen Einzelfall oder Fehlinstallation handelt.

Ich halte die Funktion für so relevant, dass es sich lohnt da hinterher zu sein.

Beste Grüße Oliver 

#8

Thomas

Co-Admin  (2023 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Was mich in diesem Zusammenhang interessieren würde ist, wenn Siquando diesen Fehler hoffentlich zeitnahm behoben hat, ob der Zugriffsschutz auch für Kunden konfiguriert werden kann.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersicht & Support für Shop 10 + Pro Web 3)

#9

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Ich habe die Fehlermeldung jetzt nochmal an Siquando gemeldet, mit der Bitte die Nachricht auch wirklich an die Entwicklung weiterzuleiten. Mal sehen.

@Thomas: Ja, es wäre sinnvoll, den Zugriffsschutz nicht nur wieder funktional einzubetten, sondern diesen auch noch für die Bedürfnisse von Shopbetreibern zu erweitern.

@Volker: Wollen wir das noch mit der Teamviewer-Session diese Woche machen? Thomas hat ja mein Problem inzwischen selber nachstellen können. Aber wir können es sehr gerne machen. Ich bin diese Woche recht flexibel.

Beste Grüße
Oliver 

#10

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Und ich bin während der Woche zeitlich eingeschränkt, da ich tagsüber IT-mäßig "direkt an der Front" tätig bin und abends natürlich auch noch diese und jene Dinge um die Ohren habe. Morgen abend ginge es aber. Weiteres diesbezüglich via PN.

Gut, daß Du Siquando nochmal kontaktiert hast. Nichtsdestotrotz interessiert mich die Ursache und würde diese gerne genau ergründen / lokalisieren.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#11

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Das Problem wurde in der Fernwartungs-Sitzung wie folgt lokalisiert:

In der Oliver mit dem Kauf des Pro Shops zur Verfügung gestellten Lizenzdatei fehlte die Permission "access", welche im Client die Funktionen des Zugriffsschutzes zur Verfügung stellt.


Diesen Fehler hat Siquando mittlerweile offensichtlich ebenfalls "gefunden" und ihn auch behoben. In einer nochmals frisch aus Olivers Kundenkonto heruntergeladenen Lizenzdatei war die Permission "access" ordnungsgemäß vorhanden. Nach Entfernung der alten Lizenzdatei aus dem Lizenzmanager, Hinzufügen der neuen Lizenzdatei und darauf folgender Aktualisierung Olivers Pro Shop 4 Projekte (die Aktivierung der Option "Neuinstallation der Komponenten erzwingen" ist hierbei nicht erforderlich) war der Zugriffsschutz in allen Projekten wieder wie gewohnt verfügbar.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#12

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Hallo Volker,

herzlichen Dank für die nette und zielführende Hilfe bei der Lösungssuche! Top!

Ich habe gerade auch Siquando darüber informiert, dass es nicht an einer "fehlerhaften" Installation oder "beschädigten" Datei lag. Überraschung! 🙂


Beste Grüße

Oliver

#13

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Kein Problem! Gern geschehen. 😉


In meiner eigenen Pro Shop Lizenzdatei (erworben am 01.10.2019) war die Permission "access" von Vornherein mit enthalten. Ich konnte den Fehler in meinem Pro Shop Client also logischerweise nicht reproduzieren. Vermutlich trifft das Problem lediglich alle "early birds", die den Pro Shop am ersten Tag bzw. innerhalb der ersten Tage nach Veröffentlichung (12.09.2019) gekauft haben.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#14

Thomas

Co-Admin  (2023 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Danke für die Info Volker. Zugriffsschutz- und Kundenkonten sind also 2 völlig verschiedene „Accounts“ und können nicht kombiniert werden. Hmm ... :/  ... irgendwie enttäuschend. Ich hätte mir gewünscht dort auch Kundenkonten betimmte Zugriffsrechte zu geben.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersicht & Support für Shop 10 + Pro Web 3)

#15

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

@Thomas: Ja, da könnte man so viele schöne Sachen realisieren, wenn es auf einer Accountbasis wäre. Absolut richtig. 

Wenigstens läuft der von Pro Web bekannte Zugriffsschutz wieder und in dem Zusammenhang...

@All: Siquando hat geschrieben:

"Sehr geehrter Herr Schwartz!

Es gab im Prinzip zwei Fehlerbilder in der ersten Generation vom Pro Shop. Es gab durchaus Fälle, bei denen der Shop nicht komplett auf den Web-Server übertragen worden ist. Das Fehlerbild sieht dann aber in der Tat anders aus. Es treten dann massivere Fehlermeldungen auf.

Es gab aber auch den Fall, dass beim Kauf die Lizenzdatei falsch generiert worden ist.

Die falschen Lizenzdateien sind automatisch in den betroffenenen Kundenkonten ersetzt worden, es gab aber keine spezielle E-Mail an die betroffenen Kunden.
Dafür möchten wir uns bei Ihnen und den anderen Kunden ausdrücklich entschuldigen."


Beste Grüße
Oliver

#16

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Die Entschuldigung von Siquando ist zumindest ehrlich und sollte so auch akzeptiert werden. Ich entnehme der Antwort allerdings auch, daß es mit den ersten Setup-Versionen noch deutlich massivere Probleme gab, da offensichtlich irgendwelche Packages, also Dateien bzw. Komponenten fehlten. Davon ist mir persönlich bisher nichts weiter bekannt.

Wie auch immer, die Entschuldigung finde ich gut. Außerdem ist es doch die Hauptsache, daß die besagten Fehler und Probleme behoben sind - was auch immer da zusätzlich noch im Argen war.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#17

OliverSchwartz

Forum-Sponsor  (8 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.turtle-media.de

Genau! Deshalb habe ich es auch gepostet, da die Entschuldigung ja auch nicht nur mir galt, sondern allen betroffenen Kunden.

Ich bin den Zugriffsschutz schon wieder fleißig am Nutzen und freue mich, dass wir eine schnelle Lösung gefunden haben.

Verglichen mit z.B. den aktuellen Problemen bei Apple macOS Catalina sind die Bugs bei Siquando bei Neuerscheinungen ja zum Glück selten, was darauf hindeutet, dass in Bonn fleißig Qualitätssicherung betrieben wird. Klappt halt nicht immer.

Beste Grüße
Oliver

#18

Volker W.

Administrator  (7226 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Ich entnehme der Antwort allerdings auch, daß es mit den ersten Setup-Versionen noch deutlich massivere Probleme gab, da offensichtlich irgendwelche Packages, also Dateien bzw. Komponenten fehlten. Davon ist mir persönlich bisher nichts weiter bekannt.

Ich muß diese Aussage bzw. Vermutung meinerseits revidieren. Ich habe mir die Pro Shop Setup-Datei soeben nochmals aus meinem Kundenkonto heruntergeladen. Der Zeitstempel in ihrer digitalen Signatur datiert auf den 9. September 2019, 07:57:34 Uhr. Das ist drei Tage vor dem Pro Shop Release am 12.09.2019.

Somit ist mit dem initial veröffentlichten Setup offensichtlich auch alles in Ordnung. In der Angelegenheit bitte somit ich um Entschuldigung.

Damit ist mir der erste Teil der von Oliver zitierten Antwort des Siquando-Supports zwar wiederum unklar, aber egal ... 😉


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

321 Aufrufe | 18 Beiträge