#1

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

SQL Fehler

Guten Morgen,

ich versuche gerade unserer Homepage nach vielen Jahren wieder Leben einzuhauchen. Unser Webspaceprovider (Unaone) hat einiges umgestellt. Ich hänge nun an einem SQL Fehler:

 

The REST Webservice raised the exception #30005 of type NGDatabaseException: "Database access failed. Database error #2: "mysqli::__construct(): (HY000/1045): Access denied for user 'k32068_db1'@'localhost' (using password: YES)"." on line 55 in file "/home/users/k32068/www/classes/db/ngdbconnector.php"

Beim VbdgAufbau mit der SQL DaBa wurde das alte Passwort nicht angenommen. Habe daher ein neues vergeben.

Kann mir jemand weiterhelfen? Vielen Dank 🙂

 



Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »W2D Fan« (18.02.2024, 11:26)
#2

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

Der Fehler wurde gefunden. 🙂

#3

W2D Fan

Co-Administratorin  (4564 Punkte)  ·   weiblich  ·   Niederlande  ·   Nachricht senden

Dann poste bitte doch auch die Antwort, damit andere User mit einem ähnlichen Problem auch was davon haben.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich. Deshalb halte ich ein "Dankeschön", nachdem jemandem geholfen wurde, für überaus angebracht und höflich.

#4

MuggelClan

Forum-Sponsor  (835 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Entsprechend den Bildern war da wohl nicht der SQL-Datenbank-Server richtig eingetragen, da dort "localhost" im Bild 2 steht. Im ersten Beitrag wird ein "Webspaceprovider" angegeben und ich denke nicht, dass hier "localhost" verwendet werden sollte.

Wäre jedoch sehr nett, wenn René hier die tatsächliche Lösung des Problem schreibt.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 

#5

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

Zu früh gefreut. Wenn ich im Programm bin und in die Voransicht wechsele, bleibt das Programm hängen und bricht ab. Beim Neustart meödet mir das System, es ist bereits ein Nutzer angemeldet.

Die 32bit Version müsste sich doch mit dem Win64 bit vertragen oder? 

In Sache SQL. Kommt die die Localhost IP rein > 127.0.0.1 ?

Hardware: OS ist Win10 pro. 16GB RAM. AMD FX 8320 8-Core Prozessor.


#6

MuggelClan

Forum-Sponsor  (835 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Mach am besten mal ein Neustart deines PC.

Wenn die Meldung erscheint, dass ein Benutzer angemeldet ist, dann einfach auf ja klicken. Diese Meldung erscheint auch, wenn du das Programm nicht ordnungsgemäß geschlossen hast, dann weiß der Server nicht, dass du dich bereits abgemeldet hast, bzw. das Programm geschlossen hast.

 

Bzgl. "In Sache SQL. Kommt die die Localhost IP rein > 127.0.0.1 ?", ja denn auf der HP von deinem Hoster steht Localhost nur auf neuem MariaDB. Bei MySQL die IP.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »MuggelClan« (12.02.2024, 17:58)
#7

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

Das Programmfenster schließt sich nach kurzer Zeit selbst. Ordnungsgemäß schließen geht nicht. Neustart gemacht. Cache, temp mit CCleaner gelöscht. IP gesetzt. Problem bleibt. Ich werde morgen Siq neu installieren. 

 

#8

MuggelClan

Forum-Sponsor  (835 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Hast du auch mit Adminrechte installiert?

Falls nicht, dann mit Adminrechte installieren. 

Es könnte aber auch sein, dass ein Viren-Programm die Software blockiert. Hast du eines eingesetzt? Wenn ja, dann schalte es mal testweise ab, oder mach entsprechende Einstellungen im Viren-Programm. 


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 

#9

MuggelClan

Forum-Sponsor  (835 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Ich hab mir dein zweites Bild genauer angesehen, kann es sein, dass du die Siquando Pro 3 Version verwendest?

 

Ergänzung:

Lese dir bitte diesen Beitrag HIER durch.
Deine Fehlerbeschreibung würde hierzu passen, dass eine nicht kompatible PHP-Version verwendet wird.

Daher auch die Fehlermeldung zu "ngdbconnector.php" aus Beitrag #1.

Für einen fehlerfreien Betrieb vom Windows-Client der Software Pro 3 ist PHP-Version 7.2 notwendig.
Mit PHP 8 hast du keine Chance, daher empfehle ich dir auf Pro 8 upzugraden.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »MuggelClan« (12.02.2024, 23:16)
#10

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

So, ich habe mir jetzt die Pro 8 Version zugelegt. Soweit, sogut. Die Software hängt sich bis jetzt nicht mehr auf. Dennoch läufts nicht richtig. Ich möchte

eine Seite löschen und bekomme diese Fehlermeldung:

"Zugriff gesperrt

Ihre Sicherheitsfreigabe reicht nicht aus, um dieses Element zu löschen...

Ich bin doch als Admin angemeldet .....

#11

MuggelClan

Forum-Sponsor  (835 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden

Hallo René,

ich denke alleine mit der Angabe dieser Fehlermeldung, kann dir hierzu ohne Hintergründe zum Hergang, nicht weiterhelfen.
Das müsste man die Fähigkeit haben das ganzrin einer Glaskugel zu sehen 😉

Ich könnte mir nur vorstellen, dass hier deine alte Einstellungen (Angaben im ProjectCentral) aus ProWeb3 nicht mit denen im SQL-Server übereingestimmt haben mit denen du mit ProWeb8 das Upgrade durchgeführt hast.
Was da genau schiefglaufen ist, kann man nur spekulieren.

Beschreibe mal genau wie du das upgerade durchgeführt hast und welche Seite sich nicht löschen läßt. Ist das nue eine Seite oder lassen sich alle Seite nicht löschen?
War vorher jemand anderes der Administrator vom Projekt?

 

Was ich auch vermute ist, dass durch deine Versuche mit ProWeb3 auch das Projekt von vorneherein gar nicht funktionsfähig in die SQLDatenbank geschrieben wurde. In diesem Fall, am besten mit einer Projektsicherung ein neues Projekt anfangen.


Mit freundlichen Grüßen

Thomas

Web To Date seit 2004, Siquando Web 12, Pro Web 8, Web Client 


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »MuggelClan« (17.02.2024, 17:27)
#12

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

Hallo Thomas,

ich habe Pro 8 installiert und über Project Central das Projekt gestartet. Das hat wohl funktioniert, aber ich konnte z.B. keine Fotos austauschen oder wie angesprochen keine Seite löschen. However, habe ich das Projekt in Pro 8 und auf dem Server gelöscht.

Gerade habe ich ein neues Projekt angelegt. Installation läuft.

Das bisherige Projekt wurde ja vor 5 Jahren erstellt und kam nicht mit der aktuellen SQL Version und der SSL Verschlüsselung zurecht. Ob ich die SQL Datenbank hätte neu anlegen müssen weiß ich nicht.

Ich hoffe, das Projekt läuft danach problemlos....

 

Beste Grüße aus dem Südwesten

René

#13

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

Hallo Thomas,

ich denke, ich habe es geschafft: die Software läuft, SQL neu angelegt und bisher keine Fehlermeldungen.

Frage: gibt es noch die Ankündigungsseite "Webseite im Aufbau"?

Wo kann ich diese finden?

Besten Dank.

 

René

#14

W2D Fan

Co-Administratorin  (4564 Punkte)  ·   weiblich  ·   Niederlande  ·   Nachricht senden

Ich heiße zwar nicht Thomas, aber ja die Ankündigungsseite "Webseite im Aufbau" gibt es noch.

Die hast du aber selbst erstellt 😉 und findest du unter Gestaltung - Under Construction-Seite


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich. Deshalb halte ich ein "Dankeschön", nachdem jemandem geholfen wurde, für überaus angebracht und höflich.

#15

René

Mitglied  (34 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://www.rene-treitz.de  ·   renetreitz

Ja, habe ich gefunden. Danke an alle. Der Beitrag ist damit erledigt! Beste Grüße René

582 Aufrufe | 15 Beiträge