#1

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Fatal error: Uncaught Error: Class 'NGUtil' not found in /homepages/21/d363984941/htdocs/led/classes/includes.php:192 Stack trace: #0 /homepages/21/d363984941/htdocs/led/index.php(2): include_once() #1 {main} thrown in /homepages/21/d363984941/htdocs/led/


Hallo,

im Programm selber sagt das Programm "404". Wenn ich die Seite im Web aufrufe, kommt folgendes:

Fatal error: Uncaught Error: Class 'NGUtil' not found in /homepages/21/d363984941/htdocs/led/classes/includes.php:192 Stack trace: #0 /homepages/21/d363984941/htdocs/led/index.php(2): include_once() #1 {main} thrown in /homepages/21/d363984941/htdocs/led/classes/includes.php on line 192


Kann damit jemand was anfangen? Ich komme nicht weiter.

Danke!

#2

W2D Fan

Co-Admin  (3261 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Vielleicht fällt jemand was dazu ein wenn du auch mal erklärst zu Was du keine Verbindung hast. Und weil du im Siquando Web Unterforum postest mit welche Version von Siquando Web (8-9-10) du arbeitest.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#3

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo,

habe es in Pro Web verschoben. Ist Siquando Pro Web 2

#4

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo Marjorie,

ich kann es aus Project Central nicht in Siquando Pro bearbeiten. Fehlermeldung 404, siehe oben

#5

W2D Fan

Co-Admin  (3261 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Ich habe diesen Beitrag verschoben in das Siquando Pro Web Unterforum und deinen anderen Beitrag gelöscht.

Wenn du im falschen Unterforum gepostet hast reicht es aus einfach zu fragen ob einer der Admins das Thema ins richtige Forum verschieben kann, dann muß das Thema nicht nochmal erstellt werden.

Danke für dein Verständnis.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#6

Thomas

Co-Admin  (1997 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Bei dieser Fehlermeldung würde ich dir empfehlen eine erneute Installation der Serverkomponenten vorzunehmen.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#7

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Vermutlich der klassischste aller Pro Web Anwender-Fehler:

WWW-Adresse und Basis-Ordner passen nicht zueinander.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#8

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Bei dieser Fehlermeldung würde ich dir empfehlen eine erneute Installation der Serverkomponenten vorzunehmen.

 Hallo Thomas,

danke für Deine Antwort. Was genau meinst Du mit "Serverkomponenten"? Die anderen Seiten erreiche ich problemlos über Siquando. Die Daten für FTP und SQL habe ich von 1und1 und die habe ich auch überprüft.

#9

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Vermutlich der klassischste aller Pro Web Anwender-Fehler:

WWW-Adresse und Basis-Ordner passen nicht zueinander.

 Hallo Volker,

danke für Deine Antwort. Ich weiß nicht genau, ob ich das richtig verstehe, aber ich habe es sowohl ohne Ordnerbezeichnung als auch mit der Bezeichnung versucht

#10

Thomas

Co-Admin  (1997 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Wenn du in Project Central das Projekt wählst kannst du rechts auf „Installieren und Aktualisieren“ klicken um die Kompenenten für Siquando Pro Web auf dem Server zu installieren. Die Ordner usw sollten natürlich korrekt installiert sein.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#11

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Die im Projekt eingetragene WWW-Adresse (oder anders gesagt die Domain bzw. Subdomain) muß beim Webhosting-Provider in exakt denjenigen Ordner geroutet sein, welcher in Deinem Projekt als Basis-Ordner konfiguriert ist. Sollte die WWW-Adresse ein Verzeichnis als Anhängsel haben, muß dieses Verzeichnis auch dem Basis-Ordner angehängt werden.


Mit anderen Worten:

Die WWW-Adresse und der Basis-Ordner müssen (!) technisch zusammen passen / synchron zueinander sein. Ansonsten wird das nichts und das Ergebnis ist und bleibt der Error "404".


Wir haben bereits 78,3 Trilliarden Themen und Beiträge zu genau diesem Thema. 😴


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#12

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Wenn du in Project Central das Projekt wählst kannst du rechts auf „Installieren und Aktualisieren“ klicken um die Kompenenten für Siquando Pro Web auf dem Server zu installieren. Die Ordner usw sollten natürlich korrekt installiert sein.

 Hallo Thomas,

Danke. Habe ich gemacht und diese Fehlermeldung erhalten. Werde mich wohl mal mit 1und1 kurzschließen müssen.libliled2.png

#13

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Die im Projekt eingetragene WWW-Adresse (oder anders gesagt die Domain bzw. Subdomain) muß beim Webhosting-Provider in exakt denjenigen Ordner geroutet sein, welcher in Deinem Projekt als Basis-Ordner konfiguriert ist. Sollte die WWW-Adresse ein Verzeichnis als Anhängsel haben, muß dieses Verzeichnis auch dem Basis-Ordner angehängt werden.


Mit anderen Worten:

Die WWW-Adresse und der Basis-Ordner müssen (!) technisch zusammen passen / synchron zueinander sein. Ansonsten wird das nichts und das Ergebnis ist und bleibt der Error "404".


Wir haben bereits 78,3 Trilliarden Themen und Beiträge zu genau diesem Thema. 😴

 Hallo Volker,

Danke. Ich bin ja der Meinung, dass dies der Fall ist.

#14

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo,

habe jetzt mit 1und1 telefoniert. Der Mitarbeiter sagte mir nach Rückfrage, man habe in den letzten Tagenn ein Serverproblem gehabt, von welchem er nicht genau wüsste, ob es behoben ist. Ich solle mal das Passwort vorläufig ändern und dann noch mal versuchen. Habe ich gemacht. Jetzt bekomme ich eine andere Fehlermeldung, aber immer noch keine Verbindung

php.png

 

#15

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Ich bin ja der Meinung, dass dies der Fall ist.

Das bringt uns bzw. Dich quasi nicht weiter. Bist Du nur der Meinung oder ist dies definitiv so? Diese Angelegenheit ist so ziemlich die wichtigste bei der korrekten Konfiguration des Projekts in Project Central.

Die korrekte Zugehörigkeit von WWW-Adresse und Basis-Ordner zueinander ist genauso wichtig wie die zwischen HTTP Target-URL und FTP Remote-Folder in w2d bzw. Siquando Web.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#16

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo, trotz mehrerer Telefonate mit 1und1 komme ich einfach nicht weiter. Kann vielleicht jemand mit dieser Fehlermeldung was anfangen? Oder was könnte ich sonst kopieren oder erklären, damit man das Problem oder den Fehler eingrenzen kann?

Danke!

datenbankfehler1.png

#17

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Die Ursache der Fehlermeldung liegt DEFINITIV (!) an fehlerhaften Zugangsdaten zur MySQL-Datenbank.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#18

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Danke, Volker. Was ich nicht verstehe, warum weder ich noch 1und1 diesen Fehler erkennen kann

#19

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Woher sollen die 1&1 Support-Mitarbeiter wissen, welche MySQL-Zugangsdaten Du wo eingetragen hast? Vermutlich ist Siquando Pro Web dort auch weniger bekannt.

Warum Du dies nicht erkennst, ist mir auch nicht klar. Gleiche die MySQL-Zugangsdaten, also

  1. Server
  2. Benutzer
  3. Datenbankname
  4. Kennwort

nochmals exakt und sorgfältig ab. Erzeuge im Zweifel bei 1&1 ein neues Datenbank-Kennwort, trage dies in Project Central im Projekt unter "SQL-Server" ein und aktualisiere danach nochmal kurz Dein Projekt. Wenn die o.g. Daten (neben denen aus den beiden anderen Bereichen "Allgemein" und "Webserver") korrekt und synchron zueinander sind, wird die Website danach reibungslos funktionieren.


Im Zweifel kann und werde ich Dir gerne - und dies auf jeden Fall zielführend! - persönlich helfen. Diesbezüglich sollte jedoch eine Hand die andere waschen. Da dieses Forum regelmäßige Kosten verursacht, würden wir uns dann über eine Forumspende Deinerseits sehr freuen.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#20

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Unnötiges Zitat gemäß Forenregeln § 2 Abs. 6. gelöscht [W2D Fan]

Hallo Volker,

danke. Ich habe mit ihnen einfach mal die Daten abgeglichen. Abgleich und neues Passwort habe ich auch hinter mir. Sie haben jetzt ein Ticket für den Fall eröffnet, weil es auch im Zuge des Wechsels 1und1 zu ionos und damit verbundenen Adressänderungen schon mal Probleme gab. Das werde ich noch abwarten und werde ich Dich dann vielleichtam besten mal anschreiben.

 

Danke

#21

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Guten Morgen,

1und1 hat geantwortet:

 

Ihre Webseite bringt aktuell folgenden Fehler: fatal error: Uncaught NGDatabaseException...

Die Ursache hierfür ist, dass Ihre Datenbank "db759155706" keinen Inhalt besitzt.

#22

ofensepp

Forum-Sponsor  (354 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.hohenlinden.info

Hallo,
hast Du schon versucht einen neue Datenbank zu erstellen. Das geht doch ratz fatz.
Benutzername:
Kennwort:
Datenbankname:
das geht doch in weniger als 5 Minuten.

#23

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo,

Danke, sorry, bin da wenig bewandert. Meinst Du diese htaccess-Datei im Verzeichnis? Da mit access irgendwas neu erstellen? 

#24

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

1und1 hat geantwortet:

Ihre Webseite bringt aktuell folgenden Fehler: fatal error: Uncaught NGDatabaseException...

Die Ursache hierfür ist, dass Ihre Datenbank "db759155706" keinen Inhalt besitzt.

Wenn exakt diese Datenbank mit definitiv korrekten Zugangsdaten (Server, Benutzername, Kennwort, Datenbankname) in Deinem Projekt in Project Central eingetragen ist, liegt für mich die Vermutung nahe, daß Du das Projekt noch nie auf Deinem Webserver installiert hast.

Project Central -> Projekt markieren -> Administrative Aufgaben -> Installieren oder aktualisieren -> "Neuinstallation der Komponenten erzwingen" aktivieren -> OK


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#25

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo Volker, danke, nein, war noch nie installiert, weil es ja nicht funktioniert hatte. Dann versuche ich das "erzwingen" mal. Danke

#26

Volker W.

Administrator  (7060 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Deine als logisch empfundene Reihenfolge ist genau verkehrt herum. Es kann niemals funktionieren, wenn das Projekt vorher nicht installiert wurde!

In dem Fall kannst Du auch die Option "Installation der Komponenten erzwingen" deaktiviert lassen, denn wenn auf dem Webserver noch nichts installiert ist, wird Projekt Central automatisch nicht "aktualisieren", sondern (vollständig mit allem Drum und Dran) "installieren".

Ich hatte Dir nur aus Sicherheitsgründen empfohlen, das "Erzwingen" zu verwenden, falls z.B. die Projektdaten auf dem Webserver beschädigt sind (bspw. durch versehentliches Löschen von wichtigen Projektordnern via FTP).


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#27

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo Volker, das "erzwingen" hat auch nur zum gleichen Ergebnis, sprich zur gleichen Fehlermeldung in "line 56" geführt. Ich melde mich nächste Woche mal bei Dir. Danke

#28

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo Volker,

habe Dir, wie angekündigt, gestern Morgen eine Nachricht geschickt

 

#29

W2D Fan

Co-Admin  (3261 Punkte)  ·   weiblich  ·   Niederlande  ·    Nachricht senden
 http://www.w2dfan.nl

Geduld ist eine Tugend!

Volker muß tagsüber seine Brötchen anderweitig verdienen und ich kann mich so vorstellen dass er wenn er Abends nach Hause kommt er zuerst andere Sachen zu erledigen sind 😉

Wenn er Zeit hat wird er sich bestimmt bei dir melden, auch wenn das etwas länger dauert.


Gruß,
Marjorie

Hilfe ist nicht selbstverständlich, deshalb halte ich ein "Dankeschön" nachdem jemandem geholfen wurde für überaus angebracht und höflich.

Viele hier im Forum veröffentlichte Scripts sind das geistige Eigentum der Ersteller und unterliegen somit das Copyright! Wenn ihr diese Scripts in eure persönliche Seite(n) oder auf Seiten für eure Kunden anwendet, ist ein Quellverweis auf den Beitrag mit dem Script nichts anderes als selbstverständlich.

#30

MiLi

Eroberer  (74 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://milz-lindemann.de

Hallo Marjorie,

Danke, davon gehe ich aus. Das war ja auch nur ein Hinweis, auf den man nicht ungeduldig reagieren muss. 😉

 

721 Aufrufe | 31 Beiträge