#1

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo zusammen,

leider komme ich allein nicht weiter 😞 und habe auch im Forum nicht die passende Antwort gefunden. 

Folgende Fehlermeldung wird angezeigt - siehe Screenshot. Kann bitte jemand helfen? Gibt es schon eine Lösung im Forum, die übersehen habe? Vielen Dank im Voraus für jeden Tipp!

Gruß Kerstin

IMG_2716.jpeg


Beste Grüße!

Kerstin 


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (27.01.2019, 22:21)
#2

Micha

Mitglied  (32 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://violent-dreamer.de

Ohne konkrete Infos wie z.B. Provider, PHP-Version, MySQL-Version, SqShop Build-Nr., SSL-URL etc.wird Dir niemand weiterhelfen können.
Mal eine erste Vermutung so ins Blaue: Wurde eine Umstellung auf https durchgeführt?


Best,
Micha

#3

Teefax

Eroberer  (62 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 https://veloteile24.ch

Lese mal hier nach...

#4

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo Micha, hallo Teefax,

guten Morgen und vielen Dank!!! Ja, der Fehler hängt offensichtlich mit der Umstellung auf https zusammen. Ich habe ein Script von IONOS (1und1) verwendet. Genaue Anleitung für CMS gibt es leider für Siquando mal wieder nicht 😞 Nach ersten Experimenten... erhalte ich nun Fehler #203 und erneute vollständige Veröffentlichung läuft. Dauert etwas...

Wenn es wieder nicht funktioniert hat, gebe ich euch die Infos an ..."Provider, PHP-Version, MySQL-Version, SqShop Build-Nr., SSL-URL etc...."

Bis später... 😃


Beste Grüße!

Kerstin 

#5

Thomas

Co-Admin  (1919 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Achte darauf dass du in den Veröffentlichungs-Einstellungen die https Adresse sowohl bei der HTTP Target-URL, sowie auch bei der SSL Target-URL einträgst.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#6

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

😢 ...leider kein Erfolg...

Die Veröffentlichung mit diesen Einstellungen läuft noch...

mceclip0.png

Hier das Script von IONOS.

mceclip1.png

 


Beste Grüße!

Kerstin 

#7

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Achte darauf dass du in den Veröffentlichungs-Einstellungen die https Adresse sowohl bei der HTTP Target-URL, sowie auch bei der SSL Target-URL einträgst.

 Hat leider nicht funktioniert. Weder beide Einträge mit https://pumpen-netshop.de noch mit https://www.pumpen-netshop.de . Entweder Fehler #200 oder Fehler #203 werden gezeigt. 😢


Beste Grüße!

Kerstin 

#8

Thomas

Co-Admin  (1919 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

#9

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Ja Thomas, neu erstellt und vollständig veröffentlicht. Der Versuch - siehe Screenshot- läuft noch einen Moment. Bin gespannt! 

 


Beste Grüße!

Kerstin 

#10

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Ja Thomas, neu erstellt und vollständig veröffentlicht. Der Versuch - siehe Screenshot- läuft noch einen Moment. Bin gespannt! 

 

 Zeigt leider wieder Fehler #203. 😢


Beste Grüße!

Kerstin 

#11

Thomas

Co-Admin  (1919 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

www.pumpen-netshop.de und pumpen-netshop.de sind unterschiedliche Domains, trage in beiden Felder exakt die gleiche Domain ein.

Die htaccess scheinst du außerdem nicht korrekt angelegt habe, da keine Umleitung erfolgt.


Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Thomas« (23.01.2019, 11:25)
#12

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

www.pumpen-netshop.de und pumpen-netshop.de sind unterschiedliche Domains, trage in beiden Felder exakt die gleiche Domain ein.

Die htaccess scheinst du außerdem nicht korrekt angelegt habe, da keine Umleitung erfolgt.

Mit zwei gleichen Einträgen habe ich es probiert. Wenn ich die IONOS Anleitung richtig verstehe, darf kein "www" davor stehen. Dann erhalte ich jedoch Fehler #200. 

Es erfolgt keine Umleitung? Aber ich lande doch auf "https" mit Schloss??? Die Veröffentlichung mit beiden Einträgen auf https://pumpen-netshop.de läuft noch. 😕


Beste Grüße!

Kerstin 

#13

Thomas

Co-Admin  (1919 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Mit verschiedenen Domains wird es nicht funktionieren. Und dein Shop ist mit und ohne www erreichbar (was unter Anderem zum leeren Warenkorb führen kann). Du solltest dich für eine Variante entscheiden, ob mit oder ohne www ist dabei dir überlassen.

Nutze für die htaccess lieber die nachfolgende Anweisung:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.domain\.de$ [NC,OR]
RewriteCond %{HTTPS} =off
RewriteRule ^(.*)$ https://domain.de/$1 [R=301,L]

Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#14

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

www.pumpen-netshop.de und pumpen-netshop.de sind unterschiedliche Domains, trage in beiden Felder exakt die gleiche Domain ein.

Die htaccess scheinst du außerdem nicht korrekt angelegt habe, da keine Umleitung erfolgt.

 Hier die htaccess vom Server:

RewriteEngine On RewriteCond %{SERVER_PORT} !=443 RewriteRule ^(.*)$ https://pumpen-netshop.de/$1 [R=301,L]

 

Ich sehe gerade, da steht .htaccess 😞 ???????? Der Punkt gehört doch da nicht hin? Jetzt warte ich die Veröffentlichung ab und dann entferne ich den Punkt vor dem htaccess. Vielleicht ist das die Lösung. Oder es gehr garnichts mehr... 😢

H I L F E-wenn sich Hausfrauen in html versuchen, kann nichts bei rauskommen... 😉


Beste Grüße!

Kerstin 

#15

Thomas

Co-Admin  (1919 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Nein, der Punkt gehört dort unbedingt hin. Der Dateiname lautet .htaccess

RewriteEngine On
RewriteCond %{HTTP_HOST} ^www\.pumpen-netshop\.de$ [NC,OR]
RewriteCond %{HTTPS} =off
RewriteRule ^(.*)$ https://pumpen-netshop.de/$1 [R=301,L]

Viele Grüße
Thomas

siquando-designs.de (ganz NEU: Santa Cruz Pro für Pro Web 3 und Apollon 10 für Siquando Shop, Tutorials, Templateübersichten & Support für Shop 10 + Pro Web 3)

#16

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Schade, leider wieder der #203-Fehler... 😞 Danke trotzdem für den Lösungsvorschlag!


Beste Grüße!

Kerstin 

#17

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Anruf bei IONOS. Ich soll alle weiteren Redirect 301 von http auf https ändern. Kann das der Fehler sein?????

Zeile 1-3 habe ich vor dem Hotline-Anruf auf die IONOS-Empfehlung zurück gestellt.

 

mceclip0%20%281%29.png


Beste Grüße!

Kerstin 

#18

Volker W.

Administrator  (6785 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Was für ein heilloses URL-Durcheinander...

Teile uns erstmal mit, exakt welche der folgenden URLs Du als Stamm-URL für Deinen Shop benutzen möchtest:

  1. http://www.pumpen-netshop.de
  2. http://pumpen-netshop.de
  3. https://www.pumpen-netshop.de
  4. https://pumpen-netshop.de


Ich gehe von 3 oder 4 aus, kann dies aktuell aber auch nur raten - und das hilft ja nicht weiter. Sobald Du dies gepostet hast, werde ich Dir so zielführend helfen, daß danach alles einwandfrei funktionieren wird.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen via PN, E-Mail, Kontaktformular usw. werden nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#19

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo Volker,

sorry für das Durcheinander. Ich tu mein Bestes 😞 Ziel ist, die Navigation stückweise so umzustellen, dass ich ein horizontales Design verwenden kann. Aber bis dahin ist es noch ein weiter Weg, vom Durcheinander mal ganz abgesehen. 

Das alles einwandfrei funktioniert... 😃 sind ja super Aussichten!!!!! Ich bin sehr gespannt, wie die Lösung lautet und wo im Moment der Fehler liegt.

Also auf jeden Fall "https", das ist klar und war auch Ziel der (versuchten) Umstellung. In den empfohlenen Codezeilen von IONOS ist "www" nicht enthalten. Ich hätte jetzt gesagt, ich stelle auf https://pumpen-netshop.de um, bin mir aber nicht sicher, ob das ok ist. Zukunftsfähig sollte die Schreibweise sein. Ist die Website am Ende mit und ohne "www"- Eingabe erreichbar?

Ich danke dir sehr für deine Hilfe! Und natürlich jedem im Forum, der Tipps zu Problemlösungen geben kann! Ist die einzige Chance, die Websitegestaltung für Laien wirklich praktikabel zu machen!

Gut's Nächtla, (wie man in Franken sagt) 🙂

 

 


Beste Grüße!

Kerstin 

#20

Volker W.

Administrator  (6785 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Schritt 1:

Den Inhalt Deiner jetzigen .htaccess (mit Punkt davor!) ersetzt Du mit exakt den folgenden Zeilen:

<IfModule mod_rewrite.c>

    RewriteEngine On
    RewriteBase /

    RewriteCond %{SERVER_PORT} !=443 [OR]
    RewriteCond %{HTTP_HOST} !^(pumpen-netshop\.de)?$ [NC]
    RewriteRule (.*) https://pumpen-netshop.de/$1 [R=301,L]

</IfModule>

###

Dort, wo ich am Schluß ### geschrieben habe, trägst Du stattdessen alle Deine Redirect 301 Zeilen wieder ein.


Schritt 2:

In allen Deinen Redirect 301 Zeilen verwendest Du als Ziel-URL jeweils https://pumpen-netshop.de/... (also mit https und ohne www.). Die drei Punkte stehen als Platzhalter für die Ordner und Seiten, welche Du weiterhin exakt 1:1 so beibehälst wie gehabt. Ob die ganzen URLs darin stimmen oder nicht, prüfe ich hier nicht. Dies überlasse ich Deiner Sorgfalt und Gewissenhaftigkeit.


Schritt 3:

In den Veröffentlichungseinstellungen Deines Projekts trägst Du sowohl bei HTTP Target-URL als auch bei SSL Target-URL https://pumpen-netshop.de/ ein. Bitte exakt dies (also unbedingt wieder mit https und ohne www.) und nichts anderes.


Schritt 4 (bei Bedarf, evtl. auch nicht erforderlich):

Ändere in den Veröffentlichungseinstellungen die Einstellung bei Webservice auf "Standardverschlüsselung", ggf. auf "Unverschlüsselte Kommunikation". Verwende letzteres nur dann, wenn "Standardverschlüsselung" nicht ordnungsgemäß funktioniert und wiederum dieses nur dann, wenn "Erweiterte Verschlüsselung" nicht ordnungsgemäß funktioniert. Ansonsten behälst Du die Option "Erweiterte Verschlüsselung" wie gehabt genauso bei.


Schritt 5:

Erstelle und veröffentliche Dein Projekt neu. Die differentielle Erstellungsstrategie reicht hierbei völlig aus.

 

Voilà, das war's!!! Gehe die Schritte in Deinem eigenen Interesse sehr sorgfältig und gewissenhaft durch. Die Probleme werden anschließend behoben sein. Ebenfalls wird Dein Shop dann sowohl via http als auch via https bzw. mit und ohne www. in allen vier Kombinationen erreichbar sein. Er wird aber jeweils immer auf https://pumpen-netshop.de weiterleiten, und zwar bei Aufruf aller darin bestehenden URLs.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen via PN, E-Mail, Kontaktformular usw. werden nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#21

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo Volker!

Zu allererst - ES FUNKTIONIERT  :-D 👍👍👍👍👍

Schritt 4 war wie vermutet ein kleiner Stolperstein. Ich musste erst mit "Unverschlüsselter Kommunikation" veröffentlichen, bevor danach die "Standardveröffentlichung" ohne den Fehler lief.

Bei der Einstellung "Erweiterte Verschlüsselung" kommt wieder der 😠 #200. Das hattest du ja schon so vermutet.

Die restliche Fleißarbeit war kein Problem, hoffentlich fehlerfrei...

VIELEN DANK FÜE DIE HILFE

und allen Forenmitgliedern gutes Gelingen, die den gleichen Fehler beheben müssen, (weil ihr Hosting-Anbieter mal wieder falsche Vorgaben zur Verfügung stellt 😡

Beste Grüße 

Kerstin

 

 


Beste Grüße!

Kerstin 


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Kerstin« (24.01.2019, 15:53)
#22

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hoffentlich fehlerfrei... 

mceclip1%20%281%29.png


Beste Grüße!

Kerstin 


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »Kerstin« (24.01.2019, 15:56)
#23

Micha

Mitglied  (32 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://violent-dreamer.de

Kerstin, noch 2 Tipps/Hinweise:

Ein Eintrag bei kanonische URL kann auch nicht schaden und aktiviere mal das Häkchen bei Benutzerzustimmung einholen/abfragen (für die DSGVO Checkbox Abfrage bei der Benutzerregistrierung).


Best,
Micha

#24

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo Micha,

vielen Dank für den Hinweis!!! Häkchen ist wieder da, wo es hingehört. Habe ich wahrscheinlich versehentlich entfernt 🙄

Aber "kanonische URL"??? Das habe ich noch nie gehört.... Bei Google stehen zwar Beschreibungen dazu aber da steige ich auf den ersten Blick 🤔 (und vielleicht auch auf den zweiten) nicht dahinter. 🤓 Gibt es eine etwas verständlichere Erklärung?


Beste Grüße!

Kerstin 

#25

Volker W.

Administrator  (6785 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Bei Wikipedia findest Du alles Wissenswerte dazu. 😉

Freut mich, daß Deine Probleme behoben sind.


Übrigens, der Spenden-Button befindet sich links oben. 😛

(Keine Pflicht, aber sicherlich hier und da auch mal angebracht.)


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen via PN, E-Mail, Kontaktformular usw. werden nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#26

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo Volker,

zu Punkt 1:

ein Fehler 👩💻 und die ganze Website "grätscht" � wieder... Da traue ich mich nicht ran, ohne Beispielzeile. Ich weiß garnicht, an welche Stelle die >>>>

<link rel="canonical" href="https://pumpen-netshop.de/unterseite.html">

>>>> eingefügt werden müsste und für welche Seiten. 😶 Die 301er Umleitung kann ich wenigstens noch irgendwie logisch nachvollziehen. 🤔

zu Punkt 2: 🙋 gerne doch!

 

 


Beste Grüße!

Kerstin 

#27

Volker W.

Administrator  (6785 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

  1. Du brauchst nirgendwo eine <link rel="canonical" ...>-Zeile einfügen. Klicke unter Datei -> Website- und FTP-Eigenschaften... -> Erstellen einfach rechts neben "Kanonische URL" auf die Schaltfläche "Auto". Danach mußt Du das Projekt via differentieller Erstellungsstrategie nochmal neu veröffentlichen und gut ist. Die besagte Zeile ist dann auf jeder Seite Deiner Präsenz automatisch da.
  2. Danke Dir vorab! 😘

Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen via PN, E-Mail, Kontaktformular usw. werden nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#28

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

🙈 ... soooo einfach? Ich glaub es nicht 😂 Wie lange arbeite ich mit dem Shop-System??? � Das Eingabefeld ist mir NOCH NIE aufgefallen! 🙈 D A N K E! 

Jetzt muss ich erst einmal Schnee schieben... ⛄🌨🌨


Beste Grüße!

Kerstin 

#29

Micha

Mitglied  (32 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://violent-dreamer.de

Schaut jetzt gut aus 👍 ... und ja, man findet auch nach Jahren immer noch Neues 😉


Best,
Micha

#30

Kerstin

Forum-Sponsorin  (50 Punkte)  ·   weiblich  ·   Deutschland  ·    Nachricht senden
 https://www.pumpen-netshop.de

Hallo Micha,

ja, hab tatsächlich im Script jetzt die "<link rel="canonical" href="https://pumpen-netshop.de/index.php" />" gefunden 😃

Super, was "ich" alles kann 😂😂😂😂😂


Beste Grüße!

Kerstin 

479 Aufrufe | 50 Beiträge