#1

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Fehler: Nicht unterstützter Videotyp oder ungültiger Dateipfad

Sehr geschätztes Forum-Team! smile_16.png 

Meine Webseite www.waldfee.at habe ich zwischenzeitlich manuell von Web 9, Design Beta, auf Web 9, Design Riga, umgestellt. Die eingebetteten YouTube-Videos funktionieren dank Walti's Code-Vorgabe immer noch prima... :-)

Nun wollte ich ein eigenes, kurzes Video (dabei beschreiben einzeln aneinandergereihte Fotos die Wanderung von Sonnenfleckengruppen über die Sonnenoberfläche) im mp4-Format mittels des Plugins "HTML5 Video" reinstellen (erstellt mit NERO Platinum 2018). Dabei erscheint ein schwarzes Feld mit der Fehlermeldung "Fehler: Nicht unterstützer Videotyp oder ungültiger Dateipfad".

Im alten Web 9 Beta-Design hat das Video als wmv-Datei im Plugin "Mediaclip" tadellos funktioniert. Im responsiven Design "Riga" wird schon beim Importieren von Dateien nur das mp4-Format erkannt und importiert. Das Video kann - bereits im Pugin eingebettet - abgespielt werden. Bei der "Vorschau im Browser" und bei der erstellten Webseite erscheint jedoch oben erwähnte Fehlermeldung. Ich denke nicht, dass das am Browser liegt...

Meine Test-Seite mit dem Video-Plugin: http://www.waldfee.at/test-seite-/index.php

Im Debugger (mit F12) erscheint Folgendes:

1
2
3
4
5
6
7
8
9
<div class="sqrpara sqrparamobilefw">
<h2 id="221180a8070bb5203">TEST - Plugin HTML5 Videos</h2>
<!-- SQWPluginH5Video -->
<figure class="sqrfig">
<video class="sqrfigcontent" width="1038" height="778" controls="controls"     >
  <source src="../downloads/sonne---ar-12665_2017.mp4" type="video/mp4" />
<p>Ihr Browser ist veraltet und unterst&uuml;tzt die Wiedergabe von HTML5-Video-Clips leider nicht. Bitte aktualisieren Sie Ihren Browser.</p>
</video>
</figure></div>

Welche Videoformate sind beim Plugin "HTML5 Video" erlaubt? Welche Programme können diese notwendigen Dateien erstellen, falls NERO das nicht kann?

Sind besondere Einstellungen bei den Web 9 Plugin-Eigenschaften / beim Konfigurieren zu berücksichtigen?

Liebe Grüße

Silvia


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (07.10.2017, 23:44)
#2

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

Vergiss die "alten" Formate wie eben wmv...

Zitat von: Spirit1968

Im alten Web 9 Beta-Design hat das Video als wmv-Datei im Plugin "Mediaclip" tadellos funktioniert. Im responsiven Design "Riga" wird schon beim Importieren von Dateien nur das mp4-Format erkannt und importiert.

 

Wenn Du Dein Video als wmv-Datei vorliegen hast, dann konvertiere sie zu mp4 und die Geschichte wird funktionieren...

 

Ich hab' keine Ahnung, was Nero kann oder nicht kann, aber wenn Du eine wmv-Datei nach mp4 umwandeln willst, dann helfen Dir Konverter, wie z.B. dieser...


Gruss

Walti

#3

Volker W.

Administrator  (6737 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

#4

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Hallöchen!

Meine Video-Datei IST in MP4 (wie oben beschrieben) - und funktioniert trotzdem nicht! smile_sad_16.png 

LG
Silvia

 

#5

Volker W.

Administrator  (6737 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

#6

Sven aus Berlin

Forum-Sponsor  (435 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden

#7

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

#8

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Inhalt der Plugin-Dateien:

SQWPluginH5VideoLegacy.ccml

1
2
3
4
5
6
7
8
9
10
11
12
<video style="width:<cc:print value="width">px;height:<cc:print value="height">px;display:block" <cc:if cond="controls">controls="controls"</cc:if> <cc:if cond="poster">poster="<cc:print value="poster">"</cc:if> <cc:if cond="muted">muted="muted"</cc:if> <cc:if cond="autoplay">autoplay="autoplay"</cc:if> <cc:if cond="loop">loop="loop"</cc:if> >
<cc:if cond="mp4">
  <source src="<cc:print value="mp4">" type="video/mp4" />
</cc:if>
<cc:if cond="webm">
  <source src="<cc:print value="webm">" type="video/webm" />
</cc:if>
<cc:if cond="ogg">
  <source src="<cc:print value="ogg">" type="video/ogg" />
</cc:if>
<p><cc:print value="copperplate" escape="html"></p>
</video>

 

SQWPluginH5VideoResponsive.ccml

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
<figure class="sqrfig">
<video class="sqrfigcontent" width="<cc:print value="width">" height="<cc:print value="height">" <cc:if cond="controls">controls="controls"</cc:if> <cc:if cond="poster">poster="<cc:print value="poster">"</cc:if> <cc:if cond="muted">muted="muted"</cc:if> <cc:if cond="autoplay">autoplay="autoplay"</cc:if> <cc:if cond="loop">loop="loop"</cc:if> >
<cc:if cond="mp4">
  <source src="<cc:print value="mp4">" type="video/mp4" />
</cc:if>
<cc:if cond="webm">
  <source src="<cc:print value="webm">" type="video/webm" />
</cc:if>
<cc:if cond="ogg">
  <source src="<cc:print value="ogg">" type="video/ogg" />
</cc:if>
<p><cc:print value="copperplate" escape="html"></p>
</video>
<cc:if cond="caption">
<figcaption><b><cc:print value="caption" escape="html"></b> <cc:print value="text" escape="html"></figcaption>
</cc:if>
</figure>

 
LG
Silvia

#9

Volker W.

Administrator  (6737 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Zitat von: Sven aus Berlin

Wer lesen kann ist klar im Vorteil Volker smile_winking_16.png :

Meine Test-Seite mit dem Video-Plugin: http://www.waldfee.at/test-seite-/index.php

Sorry, habe ich überlesen.


Die verwendete MP4-Datei hat offensichtlich nicht das für HTML5 erforderliche H.264 Video-Format.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen via PN, E-Mail, Kontaktformular usw. werden nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#10

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

...deswegen ja auch die Frage (Beitrag #7), wie denn aus der wmv eine mp4 wurde...?


Gruss

Walti


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »webchaot« (07.10.2017, 19:15)
#11

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Hallöchen!

Erst mal DANKE für eure unglaubliche Schnelligkeit beim Beantworten von Fragen - sogar an Wochenenden! Wahnsinn! smile_16.pngsmile_16.pngsmile_16.png!  

Mit NERO 2018 konnte ich die wmv-Datei in eine MP4-Datei konvertieren (durch den Export der wmv-Datei lässt sich ein anderes Format auswählen). Obwohl ich diese MP4-Datei anschließend in das Video eingebettet habe, funktioniert's nicht. Kann gut sein, dass ich Greenhorn beim Konvertieren etwas übersehen habe? Aber als Dateiformat scheint eindeutig *.mp4 auf.

Wenn ihr der Meinung seid, dass es nichts mit dem Plugin bzw. Siquando zu tun hat, begebe ich mich sogleich (na ja, morgen eben) auf weitere Fehlersuche.

Ganz liebe Grüße!

Silvia





 

 

#12

Volker W.

Administrator  (6737 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   VolkerWarmers  ·   volkerw68

Wenn die Datei nun die Extension .mp4 hat, handelt es sich noch lange nicht um eine H.264 Video-Datei.

Verwende mal den von mir in Beitrag #3 genannten Online-Konverter und versuche es dann mit der dadurch konvertierten MP4-Datei nochmal.


Viele Grüße,
Volker

Volker W. Musik & Sounds  ·  Facebook  ·  Google+  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

Hilfe-Anfragen via PN, E-Mail, Kontaktformular usw. werden nicht mehr beantwortet. Genau dafür ist dieses Forum da. Vielen Dank!

#13

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

Ich wiederhole mich ungern, aber genau deshalb...

Zitat von: webchaot

...deswegen ja auch die Frage (Beitrag #7), wie denn aus der wmv eine mp4 wurde...?

 


Gruss

Walti

#14

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Unnötiges Zitat aufgrund Forenregeln §2 Abs. 6 gelöscht. [Volker W.]


Siehe mein Beitrag Nr. 11.....

.... Mit NERO 2018 konnte ich die wmv-Datei in eine MP4-Datei konvertieren (durch den Export der wmv-Datei lässt sich ein anderes Format auswählen). Obwohl ich diese MP4-Datei anschließend in das Video eingebettet habe, funktioniert's nicht. Kann gut sein, dass ich Greenhorn beim Konvertieren etwas übersehen habe? Aber als Dateiformat scheint eindeutig *.mp4 auf.....

Auf meiner erstellten Webseite ist bereits das mp4-Video eingebettet.

LG
Silvia


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (07.10.2017, 23:35)
#15

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Hallo

Ich habe zwischenzeitlich mit dem VLC-Player die wmv-Datei in eine mp4-Datei (ausdrücklich inkl. H.264 etc.!) konvertiert. Auch dieses Video scheint in der Vorschau des Plugins nicht auf bzw. es erscheint dieselbe Fehlermeldung. Nun versuche ich es mit dem von Volker vorgeschlagenen Konverter.

Mein Freund meint, ob vielleicht beim Abschluss des Siquando-Codes etwas nicht stimmt oder ein "Codecs-Aufruf" darin fehlt?

LG
Silvia

#16

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

Nein, hier hat Siquando mal keine Schuld...   ;-)


Gruss

Walti

#17

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Jippiiiiiiiiiie.....!!!!!!!!!!!!! Mit Volker's Online-Konverter funktioniert das Video zumindest schon mal in der Browser-Vorschau!

Werde die Webseite gleich mal neu erstellen. Melde mich danach wieder.

LG
Silvia

#18

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Hallöchen

Ich bin happy, das Video funktioniert! Vielen, vielen Dank euch allen! smile_16.pngsmile_16.pngsmile_16.png Was würde ich nur ohne euer Team machen?

Die Test-Seite http://www.waldfee.at/test-seite-/index.php werde ich alsbald wieder rauschlöschen. Das Video steht nun an seinem ursprünglich vorgesehen Platz http://www.waldfee.at/astronomie-in-vorarlberg/meine-sonne/index.php - unter der Registerkarte "Sonnen-Allerlei".

Es ist echt schlimm, wie wenig man sich als Kunde auf diverse Softwareprodukte verlassen kann. Und es ist echt schön, dass es Leute wie euch gibt, die Unsereins aus daraus resultierenden Schlamasseln befreien.  

Beste Grüße & a guat's Nächtle!

Silvia


#19

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

Es ist schön, wenn Du mit unserem Forum zufrieden bist...!    :-)

Zur Verteidung von Siquando muss ich allerdings noch sagen, dass im Plugin alles ok ist, aber dass man halt darauf achten muss, dass man hierfür auch eine H.264 Video-Datei zur Verfügung stellt. Deswegen auch die penetrante Nachfrage von Volker und mir... ;-)


Gruss

Walti

#20

webchaot

Ehrenmitglied  (1295 Punkte)  ·   männlich  ·   Schweiz  ·    Nachricht senden
 http://www.webchaot.ch

P.S.

Bist Du Dir bewusst, dass Deine Site zu grossen Teilen nicht erreichbar ist...?


Gruss

Walti

#21

Spirit1968

Mitglied  (39 Punkte)  ·   weiblich  ·   Österreich  ·    Nachricht senden
 http://www.waldfee.at

Unnötiges Zitat aufgrund Forenregeln §2 Abs. 6 gelöscht. [Volker W.]


Das ist dann der Fall, wenn ich die Webseite gerade aktualisiere; das Rüberladen auf den Server dauert locker 10 Minuten. Ab jetzt (23:28 Uhr) müsste alles wieder klappen. Und die Testseite ist nun bereits wieder gelöscht.

Und wegen der MP4's...: man/frau verlässt sich eben auf das, was die Software-Hersteller so anpreisen. Dass man sich auf deren Angaben nicht wirklich verlassen kann, ist schon ärgerlich. Ausbaden müssen's jene, die nix dafür können. Wie so oft ganz allgemein im Leben.... 

A liabs Grüaßle & a guate Zit!

Silvia


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Volker W.« (07.10.2017, 23:38)
512 Aufrufe | 21 Beiträge