#1

rotzloeffler

Grünschnabel  (13 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://skiroller-store.com

Hallo,

bei mir sind Vanity URLs aktiviert.

Wenn ich jetzt der Indexseite einen Seitenamen in den Seiteneigenschaften vergebe, wird der Seitenname im Browser nicht angezeigt.

Auch nicht im Seitenquelltext im Canonical Link.

Also http://beispielseite.de/ordner/beispielseite.html löst der Browser als http://beispielseite.de/ordner/ auf und im Seitenquelltext steht auch nur:

<link rel="canonical" href="http:/beispielseite.de/ordner/" />

Wenn ich im Browser die Seite mit dem Seitennamen beispielseite.html manuell eingebe, wird diese aber auch angezeigt.

Ist das ein Fehler und wie kann ich das ändern, dass der Seitenname im Browser angezeigt wird oder wenigstens das Canonical Tag richtig geschrieben wird? 

Mir geht es da auch um Duplicate Content und um die Sitemap, die ich einreiche. Da steht der Name ja auch nicht drin. Die Seite wird dann trotzdem mit dem Seitennamen gecrawlt?

#2

Micha

Routinier  (352 Punkte)  ·   männlich  ·   Deutschland  ·   Nachricht senden
 https://violent-dreamer.de

Kanonische URL hast Du unter Website-Eigenschaften/Suchmaschinen eingetragen?
Wegen den anderen Fragen siehe hier:

.php anstelle von .html akzeptieren

Wird die Option Vanity-URLs aktiviert eingesetzt, arbeitet SIQUANDO Pro mit virtuellen URLs. Dabei wird der letzte Teil der URL immer aus der Angabe generiert, die man bei den Seiteneigenschaften unter Seitenname angegeben hat.
Da manche Seitennamen nicht auf .html, sondern auf .php enden können (weil z.B. Funktionen der Seite PHP benötigen), kann es durch das Verwenden von Vanity-URLs zu Problemen kommen.
Um diesen Problemen vorzubeugen, steht Ihnen in den Erweiterten Einstellungen die Option URLs, die auf .php enden alternativ zu .html akzeptieren. zur Verfügung.
Diese Einstellung sorgt dafür, dass beispielsweise index.html auch von index.php aufgelöst wird.
Beispiel:
Wäre also die gesamte URL 'http://www.domain.de/infos/index.html' könnte der Besucher alternativ auch 'http://www.domain.de/infos/index.php' in die Adresszeile des Browsers eingeben und die Seite würde trotzdem gefunden.
Hinweis: Die Option kann nur dann funktionieren, wenn im Ordner nicht bereits zwei Seiten vorliegen, die den gleichen Namen haben, wobei die eine mit .html und die andere mit .php endet (z.B. info.html und info.php).
Hinweis: Nach Änderung des Parameters muss der Server neu installiert werden. Ihre Angaben bleiben dabei erhalten.

URLs umleiten
Wenn ein abschließendes / fehlt
Streng genommen sind die URLs http://www.domain.de/ordner und http://www.domain.de/ordner/ nicht identisch. Viele Webserver leiten jedoch die erste (falsche) auf die zweite (richtige) um.
Über die Projekt-Einstellung URLs, bei denen ein abschließendes / fehlt, umleiten, wenn möglich kann festgelegt werden, dass SIQUANDO Pro ein solches Umleitungsverhalten automatisch anwendet, sofern dies möglich ist.
Aktivieren Sie die Option, um die Umleitung automatisch durchzuführen (Standard). Deaktivieren Sie die Option, wenn URLs, bei denen ein abschließendes / fehlt, nicht umgeleitet werden sollen.
Hinweis: Viele Browser cachen die Umleitung sehr aggressiv. In der Praxis bedeutet dies: Wurde einmal von der URL http://www.domain.de/ordner zur URL http://www.domain.de/ordner/ umgeleitet, merkt sich der Browser die Umleitung und führt sie von sich aus durch, selbst wenn die Funktion deaktiviert wurde.


Best,
Micha

181 Aufrufe | 2 Beiträge