#1

artep60

Grünschnabel  (12 Punkte)  ·   weiblich  ·   Namibia  ·    Nachricht senden
 http://www.indiri-tours.de

#2

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Lösche mal diese Zeile:

Redirect permanent /anfragen/index.php http://www.indiri-tours.de/kontakt/

Und verwende ersatzweise die folgende Zeile:

RewriteRule ^/?anfragen/(index.php)?$ http://www.indiri-tours.de/kontakt/ [R=301,L]


Viel Erfolg!


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#3

artep60

Grünschnabel  (12 Punkte)  ·   weiblich  ·   Namibia  ·    Nachricht senden
 http://www.indiri-tours.de

Hallo Volker,

 

das hat leider nicht geklappt. Es kommt immer noch eine Fehlermeldung, sie sieht nur anders aus.

So war es zuerst

mceclip0.png

 

Nun schaut es so aus

 

mceclip1.png

 

 


#4

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Versuche mal das:

<IfModule mod_rewrite.c>

RewriteEngine On
RewriteBase /

RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.xml\.php\ HTTP/ [NC]
RewriteRule ^sitemap\.xml\.php$ /sitemap.xml [R=301,L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.txt\.php\ HTTP/ [NC]
RewriteRule ^robots\.txt\.php$ /robots.txt [R=301,L]

RewriteRule ^/?anfragen/(index.php)?$ http://www.indiri-tours.de/kontakt/ [R=301,L]

RewriteCond %{HTTP_HOST} !^(www\.indiri-tours\.de)?$ [NC]
RewriteRule (.*) http://www.indiri-tours.de/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.htm !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]

</IfModule>

Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#5

artep60

Grünschnabel  (12 Punkte)  ·   weiblich  ·   Namibia  ·    Nachricht senden
 http://www.indiri-tours.de

Guten Morgen,

 

das haut auch nicht hin. Es kommt die erste Fehlermeldung wieder. Und wenn ich die Website aufrufe, wird immer nur www.indiri-tours.de/index.php angezeigt, keine Unterseite. Egal was ich anklicke.

 

Viele Grüße

Petra

#6

msoumagne

Mitglied  (33 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.soumagne.name

 Hallo Pezra,

lösche mal den Cache (Strg-F5).

Ich hatte mir mal die Seite angeschaut und alles wurde richtig angezeigt.

Beim erneuten Aufruf bekam ich auch den 404-Fehler. Nach dem Löschen mit Strg-F5 ging es wieder.


Beste Grüße

Manfred

#7

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Genauso ist es! Als ich heute morgen (mobil, und zeitlich bedingt ohne antworten zu können) Petras Beitrag gelesen habe, habe ich direkt die Funktionalität der zu diesem Zeitpunkt hinterlegten .htaccess (aus Beitrag #4) geprüft. Sie funktionierte einwandfrei und leitete völlig korrekt von /anfragen/index.php (und ebenfalls von /anfragen/) zu /kontakt/ um.


@Petra:

Browsercache löschen! Wir können (und wollen) das nicht bei jedem einzelnen Beitrag dazu schreiben. Das gilt auch nach Änderungen an der .htaccess.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#8

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

https://www.indiri-tours.de/anfragen/

https://www.indiri-tours.de/anfragen/index.php


Die Weiterleitung funktioniert wie gewünscht!

Ich setze das Thema mal auf [Erledigt]. Eine erneute Rückmeldung von Dir, Petra, wäre gut und auch hilfreich für Pro Web Anwender mit ähnlichen Anliegen gewesen.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#9

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Hallo,

bei mir ergibt sich ein ähnlicher Fall.

Das alte Verzeichnis hieß www.roeder-training.de/content/seminarprogramm

Das neue Verzeichnis heißt nun www.roeder-training.de/seminar

 

Im ProjectCentral habe ich vor ca. 1 Woche das Häkchen bei "Inhalte im Ordner 'Content' ablegen" deaktiviert und das Projekt aktualisiert.

Das hat auch gut funktioniert.

Zudem habe ich die Navigationsstruktur meiner Website www.roeder-training.de vereinfacht, um evtl. ein besseres Google Ranking zu bekommen.

Nun funktionieren die alten Links in Google natürlich nicht mehr. Die 404-Fehlerseite habe ich als Übergangslösung mit Link auf die Homepage individualisiert.

Um meine alten Links direkt umzuleiten habe ich in Project Central in den erweiterten Einstellungen im Fenster "Apache.htaccess bearbeiten"

folgendes hinterlegt:

RewriteEngine On
Redirect permanent /seminarprogramm https://www.roeder-training.de/seminar

Wenn ich im Internet Explorer das (alte) Verzeichnis 

https://www.roeder-training.de/seminarprogramm/

aufrufe, kommt die (von mir individualisierte) 404-Fehlermeldungsseite mit der URL:

https://www.roeder-training.de/seminar/?ngq=/seminarprogramm/

statt umzuleiten auf:

https://www.roeder-training.de/seminar/

Ich muss noch viele andere Unterseiten ändern/umleiten.

Kann mir bitte jemand helfen?

Danke.

Grüße

#10

Thomas

Co-Admin  (2119 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

#11

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

@Thomas:

Danke für deine Rückmeldung.

Ich komme nach wie vor nicht weiter.

Ich habe den Code weiter oben von Volker auf meine Verzeichnisstruktur wie folgt abgeändert:

<IfModule mod_rewrite.c>

RewriteEngine On

RewriteBase /

RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]

RewriteRule ^robots\.txt$ /robots.txt.php [L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.xml\.php\ HTTP/ [NC]

RewriteRule ^sitemap\.xml\.php$ /sitemap.xml [R=301,L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.txt\.php\ HTTP/ [NC]

RewriteRule ^robots\.txt\.php$ /robots.txt [R=301,L]

RewriteRule ^/?seminarprogramm/(index.php)?$ https://www.roeder-training.de/seminar/ [R=301,L]

RewriteCond %{HTTP_HOST} !^(www\.roeder-training\.de)?$ [NC]

RewriteRule (.*) https://www.roeder-training.de/ $1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME}/index.html !-f

RewriteCond %{REQUEST_FILENAME}/index.htm !-f

RewriteCond %{REQUEST_FILENAME}/index.php !-f

RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]

</IfModule>

 

Das funktioniert aber so nicht.

Es kommt im Project Central nach dem Aktualisieren des Projektes folgende Fehlermeldung. 500 Internal Server Error.

Meine Website war dann auch nicht mehr erreichbar.

Ich habe alles wieder rückgängig gemacht.

Woran kann es liegen?

 

Zum Verständnis:

altes Verzeichnis: https://www.roeder-training.de/seminarprogramm/

soll bei einem Google-Besuch automatisch umgeleitet werden auf

neues Verzeichnis: https://www.roeder-training.de/seminar/

Für einen weiteren Tipp wäre ich euch sehr dankbar.

Gruß

#12

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

auch Cache leeren hat nichts gebracht.

Selbst diese drei Zeilen bringen keine automatische Umleitung im Browser:

RewriteEngine On
RewriteCond %{REQUEST_URI} ^\/content\/seminarprogramm\/$
RewriteRule .* https://www.roeder-training.de/seminar/ [R=301,L]
 
Gruß
Marcus
#13

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Mit dem von Dir aufgeführten .htaccess-Code

<IfModule mod_rewrite.c>

RewriteEngine On
RewriteBase /

RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.xml\.php\ HTTP/ [NC]
RewriteRule ^sitemap\.xml\.php$ /sitemap.xml [R=301,L]

RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.txt\.php\ HTTP/ [NC]
RewriteRule ^robots\.txt\.php$ /robots.txt [R=301,L]

RewriteRule ^/?seminarprogramm/(index.php)?$ https://www.roeder-training.de/seminar/ [R=301,L]

RewriteCond %{HTTP_HOST} !^(www\.roeder-training\.de)?$ [NC]
RewriteRule (.*) https://www.roeder-training.de/ $1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.htm !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]

</IfModule>

sollte das funktionieren. Der darf aber nicht irgendwo ergänzt werden, sondern muß vollumfänglich via FTP-Programm gegen die dort bestehende .htaccess ausgetauscht werden. Dies setzt jedoch voraus, daß die Option "content" Ordner anzeigen in Project Central deaktiviert ist. Dies ist aber bei Dir bereits der Fall.

Anschließend Browsercache leeren!


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#14

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

#15

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Hallo Volker,

vielen Dank für deine Rückmeldung.

Ja, die Seite ist bei Strato gehostet. 😢

Ich habe wie du oben beschrieben hast, die neue .htaccess genau so angelegt und per Filezilla hochgeladen und die alte ersetzt.

Nun ist die Website trotz Browsercache-Leerens überhaupt nicht mehr erreichbar.

Es kommt folgende Fehlermeldung im Browser, wenn man die Website aufruft:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at service@webmailer.de to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

 

Gibt es nun noch eine Möglichkeit, das Problem zu lösen?

In der Zwischenzeit lade ich die alte .htaccess wieder hoch, damit die Website erreichbar ist.

In der alten steht übrigens bis dato folgender Code:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]
</IfModule>

 

Gruß

Marcus

 

 

#16

Micha

As  (245 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://violent-dreamer.de

Wie Volker schon schrieb, Strato... mach' einfach einen simplen 301 Redirect, alles andere funktioniert m.E.n. eh nicht bei Strato und führt wie Du bereits selber bemerkt hast, immer nur zu Fehlermeldungen. Ergänze die funktionierende htaccess daher einfach um:
Redirect 301 /seminarprogramm/ https://www.roeder-training.de/seminar/


Best,
Micha


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »Micha« (25.02.2020, 18:45)
#17

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Hallo Micha, vielen Dank für deine Rückmeldung.

Wenn ich dich richtig verstanden habe, sieht dann meine .htaccess wie folgt aus:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /content/
RewriteRule ^(.*)$ /$1 [R,L]
Redirect 301 /seminarprogramm/ https://www.roeder-training.de/seminar/
</IfModule>

 

Habe sie mit FileZilla hochgeladen.

Ergebnis: Es wird die Fehlerseite 404 aufgerufen und in der URL steht, trotz Cache-Leerens:

 
Gruß Marcus
#18

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

@Micha

…bzw dieser Code geht auch nicht:

 

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]
Redirect 301 /seminarprogramm/ https://www.roeder-training.de/seminar/
</IfModule>

#19

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Die mit Redirect 301 beginnenden Zeilen funktionieren im Zusammenhang mit Pro Web nicht, da alle Links virtuell (Stichwort mod_rewrite) sind und tatsächlich auf dem Server gar nicht existieren. Sprich da kollidieren zwei Welten miteinander. Redirect 301 stellt mit Web und Shop Classic hingegen kein Problem dar.

Sprich hier müssen auf mod_rewrite basierende Rewrite Rules zum Einsatz kommen. Warum Strato hier wieder einen Internal Server Error bringt, ist mir ein Rätsel. Ich kann und will solche auf Strato basierenden Probleme aber einfach nicht mehr supporten.

Seit Jahren gibt es hier im Forum im Zusammenhang mit Webhosting-Paketen von Strato gefühlt tausend für mich völlig unvertretbare Fehler und Probleme. Das ist generell nur noch "Neverending Story" und effektiv vertane Zeit. Ich kann in der Angelegenheit immer wieder nur zu einem sofortigen Providerwechsel raten!

Zeige / zeigt Strato Webhosting-Paketen den Rücken, das hat keinen Zweck! Gleiches gilt für T-Online.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#20

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Hallo Volker,

vielen Dank.

Ich dachte schon, es liegt an mir, da Laie.😉

Kannst du denn einen Provider empfehlen, der mit Pro Web problemlos läuft? z.B. all inkl? 

Danke.

Ansonsten lasse ich es erst mal so wie es ist und hoffe, dass die toten alten Links bei Google irgendwann verschwinden. Blöd ist nur, dass die bei den Suchergebnissen immer noch ganz oben stehen und die neuen noch nicht sichtbar sind.

Gruß

Marcus

 

#21

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

#22

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Vielen Dank, Volker!

#23

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

#24

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

👍

#25

Thomas

Co-Admin  (2119 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Was hilft ein Umzug, bei einer falschen Umleitung?

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.xml\.php\ HTTP/ [NC]
RewriteRule ^sitemap\.xml\.php$ /sitemap.xml [R=301,L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.txt\.php\ HTTP/ [NC]
RewriteRule ^robots\.txt\.php$ /robots.txt [R=301,L]
RewriteRule ^/?seminarprogramm/(index.php)?$ https://www.roeder-training.de/seminar/ [R=301,L]
RewriteCond %{HTTP_HOST} !^(www\.roeder-training\.de)?$ [NC]
RewriteRule (.*) https://www.roeder-training.de/ $1 [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.htm !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]
</IfModule>

Die htaccess würde super funktionieren, wenn du www.roeder-training.de/seminarprogramm/ umleiten möchtest, weiter oben schreibst du aber ....

Das alte Verzeichnis hieß www.roeder-training.de/content/seminarprogramm
Das neue Verzeichnis heißt nun www.roeder-training.de/seminar

Die korrekte htaccess müsste also

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap\.xml$ /sitemap.xml.php [L]
RewriteRule ^robots\.txt$ /robots.txt.php [L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /sitemap\.xml\.php\ HTTP/ [NC]
RewriteRule ^sitemap\.xml\.php$ /sitemap.xml [R=301,L]
RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /robots\.txt\.php\ HTTP/ [NC]
RewriteRule ^robots\.txt\.php$ /robots.txt [R=301,L]
RewriteRule ^/?content/seminarprogramm/(index.php)?$ https://www.roeder-training.de/seminar/ [R=301,L]
RewriteCond %{HTTP_HOST} !^(www\.roeder-training\.de)?$ [NC]
RewriteRule (.*) https://www.roeder-training.de/ $1 [R=301,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.htm !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule ^(.*)$ /index.php?ngq=/$1 [QSA,L]
</IfModule>

sein.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Shop und Apollon 10 für Siquando Shop, Templateübersicht & Support für Shop 10 + Pro Web 3)

#26

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Hallo Thomas,

vielen Dank für deinen Beitrag.

Das funktioniert auch nicht.

Ich habe deine obige geänderte .htaccess per FileZilla hochgeladen und die dortige ersetzt.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at service@webmailer.de to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

 

 

Scheinbar ist es so, wie Volker schreibt.

Ich ziehe nun einen Providerwechsel in Betracht oder lasse es so sein.

Habe Google per Search Console die neuen Links mitgeteilt.

Dauert vermutlich.

Gruß

Marcus

#27

Volker W.

Administrator  (7653 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Meine Empfehlung: Lasse Strato hinter Dir bzw. diesen "Provider" Dich von hinten sehen! Wechsle zu All-Inkl.com.


Nichtsdetotrotz muß ich einen neuen Hinweis loswerden:

Die o.g. von mir empfohlene .htaccess führt seit der 3er-Version von Pro Web leider immer auf die 404-Fehlerseite. Dies habe ich nun auch bei mir nachstellen können.

(Das Auftreten des "Internal Server Errors" ist allerdings ein Strato-only Problem, womit ich mich nicht befassen werde! Strato-Webhosting ist für mich der Abgrund an Zumutung und Ursache für gefühlt tausend nicht erklärbare technische Fehler.)

Da ich definitiv (!) weiß, daß diese Rewrite-Umleitungen früher funktionierten (offensichtlich bis Pro Web 2), liegt dies wohl an der Einführung der Fehlerseiten, daß die Umleitungen mit Pro Web 3 nicht mehr funktionieren. Leider lassen sich die Fehlerseiten im Pro Web 3 Client nicht deaktivieren.


@Thomas:

Hast Du eine spontane Idee, wo man die Fehlerseiten evtl. im PHP-Code deaktivieren kann?


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#28

Thomas

Co-Admin  (2119 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://siquando-designs.de

Adressen umzuleiten die „content“ enthalten scheint etwas tricky zu sein, in dem Fall muss nämlich die htaccess im Ordner content angepasst werden:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /content/

RewriteRule ^/?seminarprogramm/(index.php)?$ https://www.roeder-training.de/seminar/ [R=301,L]

RewriteRule ^(.*)$ /$1 [R,L]

</IfModule>



@Volker: Die Umleitung erfolgt durch die Funktion HeaderNotFound aus der Datei classes/util/ngutil.php. Unter Anderem wird die Funktion dann in der Datei classes/renderer/ngrenderpage.php aufgerufen.


Viele Grüße
Thomas

siquando-designs.de (NEU: KARO Flex Layout, Santa Cruz Pro für Pro Shop und Apollon 10 für Siquando Shop, Templateübersicht & Support für Shop 10 + Pro Web 3)

#29

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Hallo Thomas,

ich danke dir vielmals!

😃 😃 😃

Es klappt!

Ich schreibe dann in diese .htaccess im Verzeichnis analog zu diesem Code auch die vielen anderen Unterseiten, die nicht mehr gültig sind und umgeleitet werden müssen.

Richtig?

Viele Grüße

Marcus

#30

sturmius

Forum-Sponsor  (16 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.roeder-training.de  ·   roedertraining   ·   marcus.roeder_1

Ja, es funktioniert.

Ich mache also immer so weiter:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /content/
RewriteRule ^/?seminarprogramm/(index.php)?$ https://www.roeder-training.de/seminar/ [R=301,L]
RewriteRule ^/?wir-ueber-uns/(index.php)?$ https://www.roeder-training.de/warum-es-uns-gibt/ [R=301,L]
RewriteRule ^/?service/(index.php)?$ https://www.roeder-training.de/kontakt/ [R=301,L]
RewriteRule ^/?seminarprogramm/azubi-schulungen/e-learning/(index.php)?$ https://www.roeder-training.de/seminar/ausbildung/e-learning/ [R=301,L]
RewriteRule ^(.*)$ /$1 [R,L]
</IfModule>

 

Danke nochmals, Thomas.

708 Aufrufe | 30 Beiträge