#1

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Im Link zwischen Band und index ist ein doppelter Slash-Strich und dadurch Fehlermeldung in der Search Console

Hallo liebe Forengemeinde,

ich war lange nicht hier, habe aber immer mal wieder ins Forum geschaut ohne mich einzuloggen.

Bei meiner Homepage lief alles rund und ich war zufrieden.

Bei meiner Umstellung von normaler Seite auf responsive Seite gab es damals einige Probleme und Volker hat mir super geholfen und bis zum 19.04.2020 lief alles perfekt. Das damalige Problem war das ich den Ordner mobile/smartphone auch mit gelöscht hatte und dieser aber auf dem Server mit einer Subdomain verknüpft war. Unterordner "mobile" angelegt, Verknüpfung mit der Sub-Domain wieder im Server wieder hergestellt, eine htaccess im Ordner "mobile" mit einem Redirect 301 von Volker auf die Hauptdomain eingefügt, dann einen Eintrag in die htaccess der Hauptdomain und schon lief es. Danke noch mal!!!

Der Rest in der htaccess sind Umleitungen von den alten zu vielen Unterseiten auf die neue Seite mit weniger Unterseiten und dafür übersichtlicher.

Nun bin ich heute hier weil ich seit dem 19.04.2020 ein Problem über die google search console bekommen habe und ich hoffe ihr könnt mir helfen.

In einem Link ist zwischen band und index jetzt ein doppelter Slashstrich band//index.php und das hat zu folge, dass die Seite nicht mehr richtig angezeigt wird und diese 3 Meldungen kommen

Google%20Search%20Console.jpg

  1. Text zu klein zum Lesen
  2. Elemente zu dicht beieinander
  3. Inhalt breiter als der Bildschirm

Diese 3 Fehlermeldungen beziehen sich nur auf eine Unterseite "Band" alle anderen sind O.K.

 

Zuerst dacht ich, das Problem liege bei google selbst und habe im google-Hilfeforum gefragt.

Ich bekam Ratschläge, das evtl. ein Plugin diesen Fehler verursacht. Daraufhin habe ich das Flow Slider Plugin auf der Bandseite gelöscht, cache im CDN gelöscht und es sah erst alles gut aus.

Dann habe ich den Tipp bekommen ein Redirect 301 einzurichten. Das hatte zur Folge, dass ich eine Fehlermeldung "Zu viele Redirects" in Chrome bekommen habe und die Seite war gar nicht mehr zu erreichen. Alles wieder rückgängig gemacht.

 

Ich poste hier mal meine Konfigurationen und hoffe ihr könnt mir helfen.

Umleitung aus dem Ordner Mobile zur Hauptseite wegen Umstellung auf responsive

htaccess%20mobile%20-%20smartphone.jpg

 

Die Einleitung mit allen Umleitungen in der htaccess Hauptdomain Agent Dee.

htaccess%20Teil%201.jpg

Die Umleitungen von den alten Unterverzeichnissen auf neue. Am habe ich die Empfehlung des Redirects 301 aus dem Google Hilfeforum wieder deaktiviert.

htaccess%20Teil%202.jpg

Fehlerseiten abfangen

htaccess%20Teil%203.jpg

Ich bin echt verzweifelt!

Es wäre echt toll wenn ihr mir helfen könntet.

 

Gruß

Rene

#2

deekay

Forum-Sponsor  (299 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.lippe-event.de

Du hast jetzt ein responsives Design am Start?! - Warum dann noch die Umleitung auf die Mbilversion??

Ich würde die Subdomain dann mit der passenden Seite des responsiven Designs verknüpfen.

 

 

#3

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo deekay,

Es gab damals eine Menge docs-Fehler auf dem Server. Deshalb frage ich ja hier um meine Fehler die ich wohl gemacht habe abzustellen.

Es gibt ja auch keine Mobile-Seite mehr, es ist ja ein Redirect 301 davon auf die Hauptdomain eingerichtet worden.

Alles was weg kann / muss / soll gern.... Ich bin aber ohne Anleitung von einem erfahrenen User was htaccess betrifft total aufgeschmissen.

Ein Fehler habe ich wohl schon entdeckt. In der htaccess unter #Umleitung mobile/smartphone/ ist wohl der falsche Pfad. 

Aber früher deuteten die Fehlermeldungen auf diese Pfad hin und es lief ja auch bis zum 19.04.2020 alles gut.

Denn der Ordner mit der verlinkten Sub-Domain liegt nur auf mobile und nicht auf ?mobile/smartphone/? 

 

Gruß

Rene


Dieser Beitrag wurde bereits 2 mal bearbeitet, zuletzt von »ReteSW8« (25.04.2020, 13:57)
#4

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

@Rene:

Du schreibst zwar sehr viel, aber wo man klicken muß oder welche URL man eingeben muß, um auf die von Dir genannte Doppelslash-URL zu kommen, teilst Du nicht mit.

Von daher: Keine Ahnung, wie ich / man Dir helfen soll.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#5

Paulemann

Hero  (838 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.webdesign-bf.de

Ist im Screenshot Volker. Habe mir Mal die Mühe gemacht und abgetippt. Und ja, auf dem Smartphone ist der doppelte Slash zu sehen. Leider ist der Rest auch Schrott.

Ansonsten ist das sowas von vergeblicher Liebesmüh, wo doch ein responsive Design alle Probleme lösen würde.

 


Gruß

Paulemann

Webdesign-BF - Pro 5 Mein Kleingewerbe

Heikes-Keramik - Pro 5 Projektbetreuung

Win-Zeit - Pro 5 Nostalgieseite

#6

deekay

Forum-Sponsor  (299 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.lippe-event.de

Das war ja mein Ansatz. Wenn man ein responsives Design hat brauche ich nur noch dieses Design. Und Subdomains die nur aufs Handy verweisen sind schon lange tot (also out)

#7

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Ist im Screenshot Volker. Habe mir Mal die Mühe gemacht und abgetippt. Und ja, auf dem Smartphone ist der doppelte Slash zu sehen. Leider ist der Rest auch Schrott.

Das händische Eintippen des Doppelslash-Links http://www.agent-dee.de/band//index.php, welchen ich natürlich entdeckt habe, hilft ja nicht weiter.

Wenn ich z.B. https://www.warmers.de/sounds/korg//m1-t-serie/ händisch in den Browser tippe, wird ja ebenfalls keine vernünftige Seite angezeigt. Und bei Eingabe von https://webdesign-bf.de/common/info//anpassungen.html auch nicht.


Die Frage ist:

Was muß man machen bzw. wo muß man klicken, damit man von der Website auf diese falsche URL weitergeleitet wird? Die Ursache/Quelle des Doppelslashs gilt es ja zu ergründen.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#8

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

 

 

#9

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Guten Morgen zusammen,

das Thema beschäftigt mich so sehr, das ich nicht mal mehr schlafen kann. 

Sorry, das ich vergessen habe zu schreiben wo man klicken muss.

In der Google Suchmaschine einfach Agent Dee eingeben und dann auf Band klicken.

Ganz unten im Bild sieht man den falschen Link.

Sorry für #8 weis nicht wie das passiert ist 😞

 Suchmaschine.jpg

Gruß

René


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »ReteSW8« (26.04.2020, 06:28)
#10

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Ist im Screenshot Volker. Habe mir Mal die Mühe gemacht und abgetippt. Und ja, auf dem Smartphone ist der doppelte Slash zu sehen. Leider ist der Rest auch Schrott.

Ansonsten ist das sowas von vergeblicher Liebesmüh, wo doch ein responsive Design alle Probleme lösen würde.

 

 Hallo Paulemann,

es ist doch ein responsive Design. Ich habe doch damals darauf umgestellt und es von Cojo sogar anpassen lassen.

Und es ist auch kein Smartphone-Pfad im Design angegeben.

Ich habe damals einen Fehler in der htaccess gemacht und plötzlich kamen ganz viele Server-Fehler.

Dann habe ich den Ordner die alte Sub-domain m.agent.... wieder aktivert,den Ordner manuell angelegt und ein Redirect 301 auf die Hauptseite in diesem Ordner angelegt.

Dann noch ein Redirect 301 auf alle einkommenden Anfragen auf mobile/smartphone umgeleitet. 

Alle Fehler verschwanden nach und nach und alles lief einwandfrei bis zum19.04.2020.

Gruß

Rene


Dieser Beitrag wurde bereits 1 mal bearbeitet, zuletzt von »ReteSW8« (26.04.2020, 13:42)
#11

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

#12

deekay

Forum-Sponsor  (299 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.lippe-event.de

Meine Vorschläge zum Thema:

 

1..Zum Doppelten //

In den Webmastertools kannst du doch das Problem als behoben melden und die Seite wird neu überprüft. Hast du das schon mal probiert?

2. Ich habe gerade gesehen dass du ein Kontaktformular hat und die Seite nicht mit https gesichert ist. Das solltest du aus meiner Ansicht zunächst in Ordung bringen. Hat neben einer geringeren Abmahngefahr den Vorteil auf ein besseres Google Ranking. Natürlich musst du dabei auch die ganzen redirects ändern. Aber die würde ich (um wieder auf Punkt 1 zu kommen) eh alle nochmal checken

#13

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Deekay,

Danke, das habe ich natürlich sofort gemacht und die Überprüfung ergab die gleichen 3 Fehler, definitiv wird die Seite ja auch nicht korrekt geladen durch den doppelten Slash-Strich.

Auf https wollte ich dann umstellen wenn der Fehler behoben ist. Da komme ich bestimmt noch mal auf Euch zurück.

Gruß

René

 

#14

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Noch mal eine Idee von mir.

Sollte ich die Mobile Sub.Domain m.agent... auf dem Server und den dazugehörigen Ordner löschen? Vielleicht liegt es doch daran? 😞

Hatte aber eigentlich über 2 Jahre so funktioniert. 😞

 

Gruß

René

#15

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Mit Siquando Web und/oder der .htaccess hat das ganze quasi nichts zu tun. Du solltest in der Google Search Console (früher Google Webmastertools) den fehlerhaften Link schlicht und ergreifend entfernen lassen.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#16

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo Volker,

vielen Dank für deine Untersuchungen und Mitteilung.

Das habe ich nie gemacht und um kein Fehler zu machen hier mal ein Bild von dem Entfernungstool.

Ich denke der Eintrag ist so richtig?

Link%20entfernen.jpg

Das ist ja für sechs Monate muss ich zusätzlich einen Eintrag robots.txt machen oder erst einmal die 6 Monate abwarten?

Gruß

René

#17

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

JA. Der Eintrag wird sich in den Suchergebnissen automatisch nicht mehr bilden (auch nicht nach Ablauf von sechs Monaten), da der Link ja nirgendwo im Web existiert.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#18

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Super und Danke.

Hier die letzte Antwort die aus dem Google-Hilfe-Forum erhalten habe:

Irgendwo werden diese Redirects auf die falsche URL erzeugt, wo ist von aussen unmöglich zu sagen.
Aber das habe ich ja schon in meinem 1. Post erwähnt: Tatsache wird wohl sein das wir von Google da sehr wenig helfen werden können falls es sich um ein CMS handelt.

 

Noch 2 Fragen an dich im nachhinein.

1. Kann ich die alte Sub-Domain für die ehemals Mobile-Seite m.agent..usw und die verknüpfte Datei ohne Bedenken vom Server löschen.

2. Wie muss ich die 3 Einträge in der htaccess (siehe Bild) anpassen, damit ich auf https umstellen kann?

Ich weiß, das ich das Zertifikat bei 1 und 1 beantragen bzw. aktivieren und die Seitenumleitungen in der htaccess dann von http auf https umstellen muss.

htaccess%20Teil%201.jpg 

Gruß

René

#19

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Noch 2 Fragen an dich im nachhinein.

Nicht an "mich", sondern an alle hier. Das Forum bin nicht ich, sondern die gesamte Community aus schon weit über 3.300 Mitgliedern.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#20

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Oh sorry, ich war nur so in Gedanken und da ich gerade hier mit dir geschrieben habe.

NATÜRLICH war die Frage an alle gerichtet ..manchmal ist man ein Dussel  🙂

#21

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Hatten wir hier im Forum schon gefühlt 100 mal...

In Deinem Fall:

<IfModule mod_rewrite.c>

    RewriteEngine On
    RewriteBase /

    RewriteRule ^(.*).html$ $1.php [R=301,NC]

    RewriteCond %{SERVER_PORT} !=443 [OR]
    RewriteCond %{HTTP_HOST} !^(www\.agent-dee\.de)?$ [NC]
    RewriteRule (.*) https://www\.agent-dee\.de/$1 [R=301,L]

    RewriteRule ^/?mobile/smartphone/?(.*) /$1 [R=301,L]

</IfModule>

Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#22

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Vielen lieben Dank für alles!!!

Nur noch mal zu Punkt 1. zurück.

1. Kann ich die alte Mobile-Sub-Domain m.agent-dee..., die ich damals für das alte nicht responsive Design eingerichtet habe, und die verknüpfte Datei ohne Bedenken vom Server löschen?

Da sich alle Fehlermeldungen aus Februar 2018 aufgelöst haben brauche ich sie ja nicht mehr oder doch noch so belassen? 

Gruß

René

#23

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Insofern es noch irgendwo im Web Links gibt, welche auf diese Subdomain verweisen, würde ich sie nicht löschen, sondern via .htaccess auf die Hauptdomain weiterleiten lassen.

Wenn das nicht der Fall ist (keine Links dahin im Web), kannst bzw. solltest Du diese vollständig löschen.

Was meinst Du mit verknüpfter Datei??


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#24

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Ok, dann werde ich mal bei Google und in der Search Console checken ob da noch link existieren.

Mit der verknüpften Datei war mal wieder ein Schreib/Denkfehler. Ich meinte den Ordner für die Sub-Domain m.agent-dee den ich im Root-Verzeichnis des Servers angelegt und verknüpft habe.

Wie leite ich korrekt per htaccess mit einem redirect 301 m.agent-dee auf die http://www.agent-dee.de weiter?


Gruß

René

#25

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Diese Frage hatte ich bereits erwartet. Mit folgender .htaccess im Stammverzeichnis der Subdomain:

<IfModule mod_rewrite.c>

	RewriteEngine On
	RewriteBase /

	RewriteRule (.*) http://www.agent-dee.de/$1 [R=301,L]

</IfModule>


Schade, daß bei sowas niemand anderes mal antwortet bzw. dies nicht einfach mal selbst recherchiert wird. Das ist ja wirklich kein Hexenwerk.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

#26

ReteSW8

Eroberer  (55 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 http://www.agent-dee.de

Hallo und vielen Dank.

Ich habe natürlich recherchiert und bin da auf eine Variante gestoßen.

Und da war es so erklärt. Alle Anfragen werden auf die angegebene Domain mit einem Rückgabewert von 301 weitergeleitet.

RewriteEngine on

Redirect 301 / http://www.agent-dee.de/

Hier wird bei einem Redirect-Checker eindeutig der Code 301 ausgegeben und die Seite wird korrekt umgeleitet. Bei Einträgen in der htaccess bin ich echt aufgeschmissen.

Bei deiner Variante steht folgendes erklärt:

Hat sich die ganze Domain einer Webseite geändert, kann man die folgenden Zeilen in der .htaccess-Datei einfügen um wirklich Alles (Webseiten und alle Unterseiten) weiterzuleiten:

Also ist mein Eintrag absolut falsch?

Noch eine Frage zu der ersten Zeile <IfModule mod_rewrite.c> Diesen Befehl brauche ich doch nur eintragen wenn ich auch direkten Zugriff auf das Modul mod_rewrite_c habe und das habe ich bei meinem Hosting-Paket bei 1 und 1 nicht.

Der Link mit dem doppelten Slashstrich hat sich trotz der vorübergehenden Entfernung in der Search Console wieder bei Google gebildet. Die Entfernung war auch nach 3 Tagen in der Search Console abgelaufen (sollte eigentlich für 6 Monate entfernt werden).

Jetzt habe ich den einen Redirect 301 in meiner htaccess noch einmal geändert von Band/ auf Band/index.php (Vielleicht ist/war das der Fehler!), den CDN-Cache gelöscht und die vorübergehende Entfernung noch einmal beantragt. 

 

Mal sehen was passiert. Ich bin echt überfragt wo das herkommt.

 

Gruß

René

 

#27

Volker W.

Administrator  (7652 Punkte)  ·   männlich  ·   Deutschland  ·    Nachricht senden
 https://www.warmers.de  ·   vwarmers  ·   vwarmers  ·   volkerw68

Bei Deiner Version werden alle aufgerufenen URLs auf die Ziel-Startseite umgeleitet. Bei der von mir aufgeführten Variante werden alle aufgerufenen URLs zu den jeweils synonymen Ziel-URLs weitergeleitet.

Das einklammernde <IfModule mod_rewrite.c>...</IfModule mod_rewrite.c> sorgt lediglich dafür, daß auf Servern ohne mod_rewrite die gesamte darin liegende Befehlskette schlicht und ergreifend ignoriert wird. Ansonsten käme es dort zu schwerwiegenden Fehlern und entsprechenden Fehlermeldungen.

1&1 unterstützt sehr wohl mod_rewrite.


Viele Grüße,
Volker

Über mich  ·  Volker W. Musik & Sounds  ·  Facebook  ·  Twitter  ·  Instagram  ·  StayFriends  ·  LinkedIn  ·  XING

375 Aufrufe | 27 Beiträge